Skip to Content
avatar image
Former Member

Passing user credentials

Hello everybody.

I am having an issue I don't know what else to do to resolve. This is related to passing user credentials when doing a BAPI call to do a Production Order confirmation when using the JCO connection.

By looking into this forum for an answer, I found some threads that are already covering my issue, but I believe all of the recommendations are already applied.

These are :

Configuration in SAP MII:

u2022 In the JCO action block (for RFC or BAPI call) in the link editor, set SAPUserName property to u201C$MYSAPSSO2$u201D

u2022 Define a transaction property MYSAPSSO2 and in the link editor from the JCO action block, link it to SAPSSO2Ticket property

u2022 In MII Menu - Dataservers - XacuteConnector activate property u201CAutobindu201D

u2022 In MII Menu - System Connection Editor - JCO (used JCO connection) - activate u201CSSOu201D

The certificates have been put in place and the timezone is the same in both MII and ECC.

But still, all of the transactions are recorded using the connectiong defined account and not the user account doing the transaction in MII.

We are in MII 12.1

Any help would be appreciated.

Thanks,

Guillermo Meza

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Aug 26, 2011 at 12:57 AM

    In the action's configure dialog, do you have the Credential Alias selected or is it blank?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Adarsh, thanks for your sharing.

      Actually, our process is that ECC is authenticating the user loging into MII. That has worked well for us except in the times where ECC is down or the network connection between the site where MII server is located and the site where our ECC instance is in place is also down.

      I think my issue here is going to a bug or so. As I mentioned, it works well n 12.0 bt not in 12.1.

      Guillermo