Skip to Content

Implicit Enhacement HRPBSINCLAIMS_CLS_ACTION_CHECK not visible in debugging

Hi ,

I have implemented a implicit enhancement for function module HRPBSINCLAIMS_CLS_ACTION_CHECK with name ZHR_CLAIM_EDIT . When i am debugging this function module (i.e calling this function module from portal ) i am not able to see the enhancement in debugging mode .

Please suggest.

Omm

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Aug 24, 2011 at 09:38 AM

    Hi,

    Checked whether the Implementation you created is Active or not . Goto SE84 -> Enhancements -> Enhancement Implementations and check whether it is Active .

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Om Awasthi

      Hi Omm,

      I can see many EXIT statements in the FM HRPBSINCLAIMS_CLS_ACTION_CHECK . If it encounters EXIT statement the control will directly come out of the FM and will not execute your Implementation . So try to debug the FM line by line in R/3 with the correct data and check whether it is encountering any EXIT statement. I have tried executing and because of incorrect data i encountered EXIT statement.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.