Skip to Content
author's profile photo Former Member
Former Member

How to deactivate an Implementation for badi 'ME_PROCESS_PO_CUST' at prod

Hello Experts,

I am stuck with a strange situation during badi implementation.

First I was needed to create a Implementation for badi 'ME_PROCESS_PO_CUST' at development end,I have created it and transported it to production server.

Now I want to delete or inactivate that implementation at production server.

I am trying it , but not able to do that.

I tried to inactivate it at client server and than when transported , it says that object inactive.

Even if can be inactivated some how in production server , that will also be helpful.

So, please help me to come out of this freaking situation.

And I have a request to moderator please don't block it , if you find sir that question is already answered.please provide me the link

Thanx 2 All,

Jeet

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Aug 23, 2011 at 12:24 PM

    In SE19 change mode next to the activate button is deactivate press it the implementation wont be called.

    Are u facing any other problem...

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 23, 2011 at 12:29 PM

    And I have a request to moderator please don't block it , if you find sir that question is already answered.please provide me the link

    Not only @you: such requests are meaningless. If the question deserves to be locked for some reason, it will be locked. Moderators are not your link providers, you are supposed to look for available information yourself.

    In your question here you put some effort into describing the problem and that you are now stuck after trying something, that is the reason to leave it open.

    Also, no "sir" please, if possible 😊

    Thomas

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 23, 2011 at 02:32 PM

    Hi,

    goto SE80 and enter the details. Then try to delete all the components of the BADI implementation.

    Transport the request again to production server.

    Regards

    Shiva

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 23, 2011 at 02:44 PM

    Correct way is to deactivate in development server and transport...

    Nevertheless in case of emergency, you can allow deactivation in production server via transaction SCC4, but don't forget to close again the system after deactivation, and the object will be locked in a "repaired" status, and you wont be able to transport it again. You will have to remove the repair flag via SE03, or force import thru STMS "Overwrite Objects in unconfirmed Repairs")

    Regards,

    Raymond

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.