Skip to Content
author's profile photo
Former Member

S_RS_COMP1 authorization objects

Hi all,

I have a security requirement which wants the users to be able to see the query but not change the query. But the powerusers should be able to copy the query and play around with the definition.

I tried using the authorization object S_RS_COMP and S_RS_COMP1. it worked almost fine but for a just an issue. When a power user copies the existing query and making changes and save with a different name, it works fine .. but at his next log on if he wants to change the same query for which he was the owner, its not allowing to change , rather the user has to copy it again and make changes and save it with a new name... so for every change the user is forced to save it as a new query though for the S_RS_COMP1 object i gave full authorization for the owner.

So is there some setting i'm overlooking or is there anyother object/profile/template which would allow me to achieve this.

Thanks in advance.

Mav.

Add comment
10|10000 characters needed characters exceeded

2 Answers

  • Posted on Feb 10, 2005 at 07:37 AM

    Try TCode RSSU53 (or SU53) just after the power user has tried to change one of the existing QUeries: you should obtain the missing authorization value related to the missing authorization object of the power user.

    Did you give to the power user the Object S_RS_COMP with Type of Rep Component REP (Query) Activity 02 (Modify)?

    S_RS_COMP1 is used to control the same objects, with a check on the user name ...

    Hope it helps

    GFV

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Feb 10, 2005 at 10:34 AM

    LauQ is correct, I just want to add that the trick with S_RS_COMP1 is that you need authorization S_RS_COMP AND S_RS_COMP1 before you are allowed do make changes. This in contrary with all other authorization objects where you are authorized when one authorization object allows you.

    kr,

    Tom

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      If you are in production you should not use the BEX request, but rather open the system for changes to queries. (It's next to the button described above).

      Change the setting for queries to everything changeable (not only changeable original).

      kr,

      Tom