Skip to Content
author's profile photo Former Member
Former Member

Pricing not right when Contract created via RSPPFPROCESS job on App Server

Hello Experts,

We are facing a strange problem and need your input.

1. We upgraded from 5.2 to 7.0

2. Our development system had just the central instance with no application servers. We never faced any problem with our functionality on this system

3. On our test system, in addition to the central instance, we added an application server

4. After this was setup, we tested our Business Process - Contracts will be created from Quotations by means of a Background Job which is scheduled to pick up the Quotations in a particular status.

5. The job is the standard report RSPPFPROCESS

6. The problem occurs when the job is set to run only on the application server rather than the central instance.

7. Even the Contract is created as expected, some of the condition types in the Billing Plan Item at the Item level show an error.

8. We checked if we had a problem in our code by doing the following a. Run the report in the foreground (dialog mode) in the application server, b. Run the job on the central instance and c. Run the report in dialog mode in the central instance.

9. None of the scenarios mentioned in point 8 resulted in an erro

10. The error is observed only when the job is scheduled to run on the application server.

11. We also checked all the event callbacks which are being called and everything was ok.

We would like pointers on why the job in the application server alone creates Contracts which have error in Condition Types.

Regards,

Bala

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Aug 23, 2011 at 07:53 AM

    Hi Bala,

    so I guess the VMC is enabled on those additional application servers, but did you also deploy your custom JAVA pricing userexits on those added appservers?. You could also check the VMC log via transaction SM53 tofind error messsages related to your issue.

    Best Regards,

    Michael

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Michael,

      Yes, the VMC is enabled on both the central instance and the application server.

      The java code deployed on both are identical

      We ran quite a lot of tests and nothing turned up in the SM53 log. We also did a SAT from SM53 but we could not get any useful info regarding our problem.

      Regards,

      Bala

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.