Skip to Content

Problem with method DEFINE_BUTTON: Event-ID cleared

Hi FPM-Experts,

in the configuration I defined a button (Element-ID BTN_DETAILS / Event-ID DETAILS) with event-parameters.

When I use IF_FPM_CNR_OIF-Method define_button to change the button-property enabled,

the Event-ID of my button is getting initialized.

lo_cnr_oif->define_button(
         iv_function       = if_fpm_constants=>gc_button-alternate_function
         iv_element_id     = 'BTN_DETAILS'
         iv_enabled        = abap_true.

At PROCESS_EVENT a dummy event-ID is sent instead: FPM_ACTION_ID_2

(for debugging i called the get_buttons-method before and after define_button to find out

- ON_ACTION was definitely cleared for my button)

This does not happen for buttons without event-parameters.

I solved my problem, passing my Event-ID DETAILS again to the parameter iv_on_action,

but for me it sounds like a bug in define_button?

lo_cnr_oif->define_button(
         iv_function       = if_fpm_constants=>gc_button-alternate_function
         iv_element_id     = 'BTN_DETAILS'
         iv_on_action      = 'DETAILS'
         iv_enabled        = abap_true.

Any Expert-suggestions?

Edited by: Franz Essl on Aug 22, 2011 7:12 PM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Aug 30, 2011 at 11:04 AM

    Hello Franz,

    this issue is already known and should be fixed - could you please let me know on which release and SP you are (SAP_ABA, 7.02, 7.01, ...)?

    Thanks and best regards,

    Julia

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Julia,

      I am working on SAP_ABA 7.02 SP 007.

      (Latest Download-Version of the "MiniSAP")

      Good to hear, that its bug and not a feature 😉

      Best regards,

      Franz