Skip to Content
author's profile photo Former Member
Former Member

Dynamic Cascading parameter, allow multiple values is greyed out


I have a LOV which is a cascading prompt (Department > Employees), in crystal reports I cannot edit the dynamic parameters 'Allow multiple values' setting, it's is highlighted and non-editable.

Is this because of how I'm using the dynamic parameter in the record selection (see below) as the Crystal reports DataSource is a stored procedure?

{usp_Services_Utilisation;1.EmployeeName} = {?@ChoosenEmps}

Or is how I've created the LOV in the business view manager, intrigued why this setting cannot be changed?

Help and guidance would be appreciated, thanks


Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Aug 22, 2011 at 03:38 PM

    Hi Rob,

    If the {?@ChoosenEmps} parameter is a Stored Procedure parameter, then the 'Allow Multiple Values' WILL be disabled.

    It really does not depend on where the LOV has been created.

    If you want the stored procedure to accept multiple values, perhaps, you could modify the stored procedure to accept a delimited string. The users can then enter something like this: abc, def, ghi for the stored procedure to process.


    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member


      Sorry I should have updated this thread, I didn't see the obvious the dynamic prompt in the business view manager where the multiple values was set to false, I changed this which carries the value through to the crystal report when opened in the designer.

      Thanks for your reply.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.