Skip to Content
author's profile photo Former Member
Former Member

PSA to ODS load for 2LIS_11_VAITM

Hi,

We are loading 0SD_O01 with 2LIS_11_VAITM extractor. Initially we loaded a full repair followed by INIT without & subsequently delta. Now we needed to change the update rule start routine from infosource 2LIS_11_VAITM to ODS 0SD_O01. Therefore we had to delete the ODS data. Now as we are trying to push the data from PSA we are facing problem with INIT w/o & delta requests. These requests when pushed to ODS are not getting activated. It is throwing an error while activation stating "activation of init/delta not possible for data target as it already contains full updates". Can anybody help us out with a solution.

Thanks,

Andy Kroos

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Aug 22, 2011 at 04:29 AM

    Why are you deleting ODS data, if it is in overwrite mode then you should not have any issues with further load, delta or full doesn't matter.

    Regards,

    Durgesh.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 22, 2011 at 04:58 AM

    Hi,

    If your DSO contains small amount of data, then drop the contents of DSO and do init with transfer.

    Regards,

    Suman

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 22, 2011 at 07:25 AM

    I guess you are using 3.x datamodel. Use report RSSM_SET_REPAIR_FULL_FLAG to convert full requests to full repair. I guess there were full loads done. The loads should have been marked as full repair. Anyway use the report to set full repair flags to all full requests. You should then be able to activate the requests.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 22, 2011 at 03:03 PM

    Hi Andy

    When you execute a full load to a delta enabled target, the next delta request cannot be activated anymore. (The full load will corrupt the Delta init).

    Solutions:

    1st solution:

    Delete the existing inti for ODS.

    You can delete the contents in ODS and again run the init IP with update option "Init with data transfer"

    Now your delta and activation will go fine.

    2nd solution:

    Use the report RSSM_SET_REPAIR_FULL_FLAG to change the full loads to full repairs.

    now your activation will work fine.

    As you haven't run any full loads, try with first solution

    Regards,

    Venkatesh.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 22, 2011 at 03:16 PM

    Thanks guys for your replies. It was a full load indeed whereas it should have been marked as Full repair.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.