Skip to Content
avatar image
Former Member

HTTP Connection to External Serv in PI test connection error

Hi,

Third party has provided the URL, to get their Web Services.

I tested this URL using soapsonar tool, by doing the below technical settings:

1.No proxy

2.Basic authentication given

When i execute this, able to retrieve the data from the Non-SAP.

The same thing i'm trying from PI 7.3:

I have created RFC destination connection type G (HTTP Connection to External Serv) in PI 7.3 to connect testing to a Non-SAP(Web Service) system.

I have filled the Host name & path prefix entries from the URL.

1.No proxy

2.Provided basic authentication

& when i do the connection test, getting the below err result:

Test Result Tab:

Detail Value

Status HTTP Response 401

Status Text Unauthorized

Response Body Tab:

Server Error

401 - Unauthorized: Access is denied due to invalid credentials.

You do not have permission to view this directory or page using the credentials that you supplied.

Response Header Fields Tab:

Name Value

~response_line HTTP/1.1 401 Unauthorized

~server_protocol HTTP/1.1

~status_code 401

~status_reason Unauthorized

content-type text/html

server Microsoft-IIS/7.5

www-authenticate Negotiate

www-authenticate NTLM

x-powered-by ASP.NET

date Sat, 20 Aug 2011 08:23:55 GMT

connection close

content-length 1293

~remote_addr

~uri_scheme_expanded NONE

It is working from soapsonar but not from PI. Please help in resolving this issue.

Regards,

Balper

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Aug 20, 2011 at 08:37 AM

    Response Text Tab:

    HTTP 1.1 401 Unauthorized

    Content-Type: text/html

    server: Microsoft-IIS/7.5

    www-authenticate: Negotiate

    www-authenticate: NTLM

    x-powered-by: ASP.NET

    date: Sat, 20 Aug 2011 08:23:55 GMT

    connection: close

    Content-Length: 1293

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 22, 2011 at 02:34 AM

    Hello,

    401 is a credential issue. Re-check the username/password that you are supplying. If that does not work, try using the URL Path in the Plain HTTP Adapter (not the HTTP Destination).

    Hope this helps,

    Mark

    Add comment
    10|10000 characters needed characters exceeded