Skip to Content
author's profile photo Former Member
Former Member

Custom Adaptor Module on Soap Receiver

Hi All,

In PI 7.1.1 I have a soap receiver communication channel with a call to a simple custom adaptor module before and after the call to the XISoapAdaptorBean

The call before works displaying the message in the call. It seems that the module is not being called for the response.

This used to work in XI. What's changed?

John

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Aug 19, 2011 at 12:15 PM

    Besides the fact that you have to change the code according to PI 7.11 API, it should work the same way as in PI 3.0 and PI 7.0

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Stefan,

      Problem solved.

      I replicated the interface on XI where it worked then went back to PI adding a section to my earlier code to output the context keys. It seems to be fine.

      My problem was with the response to the message being identical to the output. A problem in the mapping and not the configuration.

      However it was your comment that it should work that made me go back and question everything again.

      Kind regards and many thanks,

      John

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.