Skip to Content
author's profile photo Former Member
Former Member

User Mappings in R/3 system

I am a bit of a novice at EP6 so i apologise if this turns out to be a simple issue.

I'm building an iView portal component which invokes a bapi but I cant establish a connection with the R/3 system.

I've read through several threads in the sdn forums and have followed suggestions made to people with similar problems; but I still can't seem to get it working.

This could be attributed to a user mapping taking place between the portal and the R/3 system. The portal userID and the R/3 userID are different however a mapping from the portalID to the R/3 user ID has been created.

I am using an IConnectorGatewayService connection using the system alias and ConnectionProperties retreived from the IPortalComponentRequest; However, I read an article mentioning that X.509 are required when iether userID's are different...

Any suggestiton?

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Feb 08, 2005 at 08:35 AM

    Hi Sergio,

    Have you checked that the basis guys have actually plugged in the SAP system. The guys I've been working with have sworn that the portal can connect to SAP but actually they have no connectivity at all. It has meant that my collegue has spent the last 2 days pulling his hair out trying to work out why his code doesn't work and in fact it will never work as the portal cant even see SAP.

    Cheers

    Richard

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.