Skip to Content
Aug 16, 2011 at 11:54 AM

R3trans check finished with return code: 12, *** ERROR: Startup of database


Hi Basis experts,

i have done system copy with option offline backup/restore.

system was installed successfully and stuck at the last phase i.e system was asking for DDIC password and after wrong try it has been locked, i tried with sap* with default password "PASS" but it was not successfull.

from SQL login it tried to locate sap* user on 000 client in table USR02, but it is not there. I inserted a parameter "login/no_automatic_user_sapstart = 0" in default profile and restarted the server but sap* user not created ()verified through table usr02)

i not able to start system by startsap, it has the following error:

biqadm> startsap

Checking BIQ Database


Database is not available via R3trans

Running /usr/sap/BIQ/SYS/exe/run/startdb

Trying to start BIQ database ...

Log file: /export/home/biqadm/startdb.log

/usr/sap/BIQ/SYS/exe/run/startdb: Terminating with error code 12

DB startup failed

if i stating DB seperately with user ORA<SID>, it's opening and then after STARTSAP is working with user <SID>ADM and system get started. but again login issue....

please suggest what can be do?

*startdb.log is as ................*

Used parameter files:


Used TNSNAMES adapter to resolve the alias



OK (10 msec)

tnsping: V2 connect to BIQ


Tue Aug 16 16:25:46 IST 2011

Connect to the database to check the database state:

R3trans: connect check finished with return code: 12

Database not available


Tue Aug 16 16:25:47 IST 2011

Shutdown database

First trying to shutdown the database - May be,

the database is in the nomount or mount state


Tue Aug 16 16:26:10 IST 2011

starting database

SQL*Plus: Release - Production on Tue Aug 16 16:26:10 2011

Copyright (c) 1982, 2007, Oracle. All Rights Reserved.

Connected to an idle instance.

ORACLE instance started.

Total System Global Area 2097152000 bytes

Fixed Size 2140184 bytes

Variable Size 1070520296 bytes

Database Buffers 1023410176 bytes

Redo Buffers 1081344 bytes

Database mounted.

Database opened.

Disconnected from Oracle Database 10g Enterprise Edition Release - 64bit Production

With the Partitioning, Data Mining and Real Application Testing options


Tue Aug 16 16:26:30 IST 2011

Connect to the database to verify, that the database is now open

R3trans check finished with return code: 12

*** ERROR: Startup of database failed

Notify Database Administrator.

/usr/sap/BIQ/SYS/exe/run/startdb: Terminating with error code 12