Skip to Content

Screen Personas 3.0 ALV grid (Guigridview control) does not work in edit mode

Hi All,

It is very difficult to change the position of ALV grid an the tabstrip in Edit mode. it simply does not select the correct thing which you want to drag. I have tried many time to simply move the whole table (ALV grid) at once, And in parts ( containershell,guigridview, gui splittershell). you can see that the selected area is not the same as the area where i am pointing with my mouse. and some selected object seems to be fixed?

What i am doing wrong with the drag and drop functionalities? We use Screen personas 3.0 with sp4

untitled.png (226.4 kB)
untitled12.png (225.9 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Dec 16, 2016 at 05:47 PM

    Neither of these screen shots seem to have the ALV grid selected. It looks like you have picked other controls on a complicated screen which are overlapping or maybe including the ALV grid you are interested in. Try to select only the proper grid control element. If first another control is selected, keep clicking until you get the right one. It may need additional clicks to get to an embedded control. Once you have that highlighted and have problems with moving it via dragging, use the coordinate field (positions) and enter the new location that way.

    Of course you should also make sure that you have the latest version of the Personas client note implemented in your system.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 05, 2017 at 07:55 AM

    Hi Tamas,

    I am trying to capture the values of 2 columns based on the row selection of ALV grid.

    I wrote a script like below which is working for normal table control but it's not working for ALV grid.

    Do I am missing something?

    var sRawRow = source.selectedRowsAbsolute;
    var sRow = sRawRow.replace(/;/g, ''); // removes semicolons,
    var nRow = Number(sRow); // converts the line number string into a JS number
    var sRollgrp = source.getCellValue(nRow, "ZZROLLING_NUMBER");

    var sRollnum = source.getCellValue(nRow, "ZZASIA_SAMPLE");


    alert(sRollgrp);

    alert(sRollnum);

    I also tried the other way round but still its not working..

    var objTable = session.findById("wnd[0]/usr/cntlGRID1/shellcont/shell");

    var firstVisibleRow = objTable.firstVisibleRow;

    session.utils.log(firstVisibleRow + '');

    var selectedVisibleRow = parseInt(session.findById("wnd[0]/usr/cntlGRID1/shellcont/shell").selectedRowsAbsolute);

    var selectedTableRow = firstVisibleRow + selectedVisibleRow;

    session.utils.log(selectedTableRow + '');

    var colName = 'ZZASIA_SAMPLE';

    var rollgrp = session.findById("wnd[0]/usr/cntlGRID1/shellcont/shell").getCellValue(selectedTableRow , colName);

    session.utils.log(rollgrp);

    session.callTransaction('ZARPS_ROLLING_CLOSE' );

    session.findById("wnd[0]/usr/ctxtP_ROLLGR").text = rollgrp;

    session.findById("wnd[0]/tbar[1]/btn[8]").press();Attaching the screen shot.Thanks

    Add comment
    10|10000 characters needed characters exceeded