Skip to Content

Wrong URL in eMail notification for subscription

Hello,

when subscribing documents inside internal document repository (EP 60254, CMColl 60250) a notification mail is sent correctly.

Inside this mail the provided subscription URL ("...subscription <documentname> was created...") ends in a "com.sapportals.wdf.WdfError" (com.sapportals.wdf.WdfException: Can't find page 'SimplePage' in XML object tree!).

The provided URL seems to be wrong. It looks like:

https:<portalserver:port>/irj/servlet/prt/portal/prtroot/com.sap.km.cm.service?ConfigFileName=SubscriptionAdministration.xml&StartPage=SubscriptionAdministrationPage

Any idea how to create notification mails with URLs pointing to the correct subscriptions?

Thanks,

Jens

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Feb 02, 2005 at 01:24 PM

    Hi Jens,

    I would like to help you, but we need to know a bit more.

    Since the link (if the <portalserver:port> is properly

    populated) looks okay, it is probably not the

    notification itself, but you can check this:

    The texts that are used to generate the mail are found

    in the file:

    \usr\sap\{PORTAL_VERSION}\global\config\cm\etc\notifications\SUBSCRIPTIONADMIN_en.xml

    Here, there should be a line that reads:

    <textspan pEventid="create">The subscription <subscriptionlink/> was created</textspan>

    You should check that this is intact. There is one such

    file for each language.

    If the problem is displaying the subscription, you might try

    calling up the Subscriptions iView and see if that works and

    check the URLs against those in the notification.

    You can find the Subscriptions iView under the

    Content Administration role, then search for "Subscriptions"

    and use the right click menu to preview the iView. If this

    doesn't work, then I think your problem is not related to

    the notifications. This would be one of the first things

    to check to isolate the problem. Please post what you learn

    so that we can help you further.

    Regards,

    Darin Krasle

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Jens Tellbach

      Hi Jens,

      I checked the formulation of the URL you sent on a

      602 portal. It worked properly. This would indicate

      that the notification part is working properly and that

      the problem must be elsewhere. Obviously, if you can

      access the iView from the PCS, the iView is working.

      It must be something inbetween. Have you tried copying

      the URL directly into the browser address bar?

      You might be able to better figure out what is going on

      by looking in the application log. This should be under

      System Administration >

      Monitoring >

      Knowledge Management >

      Application Log

      See if you can find out anything new there.

      Regards,

      Darin Krasle

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.