Skip to Content

Attachment is not displayed in message display tool MDT

Hi Experts,

Currently we are on NW 7.0 SP21

I have developed an adapter module which adds an attachment to a message and sends it via mail Adapter.

The scenario itselfs works fine but if I want to monitor the message-flow I cannot see the attachment in the Message Display Tool, only the payload is shown.

It would be nice if anyone can help me solving this issue.

Thanks a lot.

Christian

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 05, 2011 at 10:47 AM

    In MDT you can see only the message before adapter module processing.

    so you are adding the attachment in adapter module ...........you cant see this in MDT.

    Only input to Adapter module will be visible in MDT not the output from adapter module

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 05, 2011 at 01:34 PM

    Attachments are not possible to view in the Message Display Tool.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 05, 2011 at 03:12 PM

    There is a very old note (587630) for BC-XI-IS-WKB stating that the binary attachements are not shown in message monitor due to a program error. What you see might be a similar error for your release. Check with SAP.

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 08, 2011 at 06:17 AM

    OK. Thank you all for your answers but is there any possibility to view attachments which was appended via module?

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 08, 2011 at 07:35 AM

    It's not what I want to hear so therefore I have to look for a workaround.

    Thank you all for your time!

    Christian

    Add comment
    10|10000 characters needed characters exceeded