Skip to Content
author's profile photo Former Member
Former Member

Cannot delete indexes of cube in BIA

Hello Experts,

I have here a weird indexed cube in BIA. The status of cube in BIA Index Maintenance is red so I'm trying to re-index the cube. But in RSA1, the is no option to delete first the existing indexes. It seems these existing indexes are currently 'not logically assigned to the cube' so in RSA1, it appears like the cube hasn't been indexed yet. But when I try to create BIA index for this cube, the process fails due to the existing indexes in BIA.

Please help.

Thanks.

Tan

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Aug 03, 2011 at 11:26 AM

    Hi Tan,

    When you right click on your Infocube and goto Maintain the BIA index option from RSA1 and if there exists an index on the cube then system itself proposes you the option for deletion of the current index.

    You can check the following document,

    [http://help.sap.com/saphelp_nw70ehp1/helpdata/en/43/bcf9bfdd052ec5e10000000a11466f/content.htm]

    Regards,

    Durgesh.

    Edited by: Durgesh Gandewar on Aug 3, 2011 4:58 PM

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 14, 2011 at 12:36 PM

    Hi

    Check from transaction RSDDV -> give infocube and proceed clicking BIA INDEX. Check the link shared by Durgesh. That will help you in filling.

    If the indices are already availble, a message "BIA index for InfoCube XXXXXX already created and filled" will be displayed. Try deleting and rebuilding again the indices by choosing CONTINUE button. It will delete the indices.

    Close and open again, now a message "Do you want to create the BIA index for InfoCube XXXXXXX?" will be displayed.

    Choose CONTINUE and this will build the indices.

    A background job RSDDTREX_AGGREGATES_FILL will be started by your name. Monitor that. Once the job is finished, check in table RSDDTREXDIR for the cube.

    The OBJECT STATUS must be ACT and the TSTPNM must be your id. If the object status is OFF, rebuild has not happened,

    Hope this helps you.

    Regards

    Chandrasekhar

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 03, 2011 at 12:37 PM

    Hi,

    You can try to recreate the indexes, it will prompt you that the indexes are already there, and will give you an option to recreate.

    or

    you can try to analyse first from RSRV http://help.sap.com/saphelp_nw73/helpdata/en/4b/ec962aa084324ae10000000a15822b/content.htm

    or

    if nothing works use the program RSDDTREX_INDEX_DELETE and enter the cube name as variant.

    Cheers

    Tansu

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi All,

      Thanks for all of your responses (and sorry for my late reply). The problem has been solved by SAP and it turned out that when we tried to delete the index at the beginning, leftovers remained in the system; and that was the root cause of the error we encountered.

      -


      So, SAP did like below:

      ->Iooked for leftovers after executing the program RSDDTREX_INDEX_DELETE for cube ZXXXX:

      - transaction TREXADMIN

      - tab "index landscape" -> input-help -> looked for "ZXXXX"

      -> noticed a leftover of the dimension-index which was split before

      -> part 5 still existed on 1 blade

      - display index -> mark relevant row -> click button "delete index"

      -


      Afterwards I was able to activate the BWA-index.

      I hope this helps others in the future. ;D

      Great thanks!

      Tan

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.