Skip to Content
author's profile photo Former Member
Former Member

Printing zero totals in ALV List Display

Hi everyone,

I have created an ALV Grid using the function modules 'REUSE_ALV....'. I have several quantity fields (ie, MARD-LABST) that are being output. These fields are totaled via the Layout option on the ALV Grid. When these total fields are shown on the screen, values of '0.000' are reported. When printing, these values show as spaces. The line item values of zero are printed, however, only the total lines generated via the layout option become spaces. The values for fieldcat-no_zero and fieldcat-lzero are initial. Our users would like to see '0.000' for any line item or total that has no value. Does anyone have an idea on how to retain the '0.000' when printing?

Thanks for your time!

Laurie

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Jan 31, 2005 at 09:41 AM

    Hi Laurie,

    Try to convert data type Quan (ie, MARD-LABST) to NUMC in your itab field structure.

    Haris

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.