Skip to Content
author's profile photo Former Member
Former Member

PDK for .NET: Ready to Use Today

I would like to encourage you to read the weblog that I posted. /people/sap.user72/blog/2005/01/27/pdk-for-net-ready-to-use-today

If you are already using the PDK for .NET, it would be great if you could use this thread to provide some feedback on it.

Thanks,

Yossi

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Feb 04, 2005 at 06:11 PM

    Yossi,

    This sounds very interesting. Can you perform the complete development cycle on .NET platform? I mean do I necessarily have to deploy the .NET iView to an SAP WAS runtime or can I have it proxied from the SAP runtime to the .NET runtime?

    Abhinav

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      In order to run the .NET iViews you need to have SAP Portal. It means that you can develop .NET iViews completly on .NET platform (without having SAP Portal) until the point you need to preview your content.

      Yossi

  • author's profile photo Former Member
    Former Member
    Posted on Feb 04, 2005 at 10:14 PM

    I have been working with this PDK since the beta version, I love it and the development it's very easy.

    The problem is in my production environment, our portal is installed on UNIX, in a cluster, and the .NET server is on 3 windows machines with a load balancer. Some times the application works fine but some times shows the error ".NET server not running".

    We configured in the Portal something like this:

    306690150=igasnew:8050;306690151=igasnew:8060;404593350=igasnew:8080;404593351=igasnew:8090;...

    306690150=porsrv1:8051;306690151=porsrv1:8052;404593350=porsrv2:8054;404593351=porsrv2:8055;...

    "igasnew" is the name of the windows load balancer. Should we use the server names instead of the loadbalancer?

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello:

      SAP Enterprise Portal 6.0 SP 09 Patch 2, SAP WAS J2EE 6.40 SP09.

      SAP .NET PDK 1.0 patch 1

      The load balancer redirects to a different server and .net runtime instance. (By code I'm showing in which server and instance is running the .net application)

  • author's profile photo Former Member
    Former Member
    Posted on Feb 10, 2005 at 06:27 AM

    Hi All,

    We have recently started using .NET PDK 1.0 Patch1 and it works in FIRST RUN !!!!! WOW !!! . This is really awesome..With such kind of PDK, .NET community can develop Portal Application in absolutely very little time ...

    We have created number of .NET iViews using PDK. We consumed web services from .NET iView applications ...it again works perfectly...and also able to show charts and graphs in iView using Flash...

    Finally we have created SCA out of it and deployed using SDM....It works perfectly......

    Only thing I would like to mention if you can point any UI tool to Build SCA/SDA from .NET application it would be of great help.

    With SAP .MAKE utilities I was able to build SCA though.

    Also want to mention that feedback from .NET Forum is really fast which sorted out some difficulties we had.

    Overall I had great experience using .NET PDK and Enterprise Portal

    Regards

    Prashant Dambe

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 16, 2005 at 04:03 PM

    Yossi,

    when I am installing the msi-file for the Portal Development Kit 1.0 patch 1, the installation is immediately interrupted by the error 'This setup requires Microsoft Visual Studio .NET 2003' - installation incomplete...

    Although I have VS.net 2003 Enterpise Architect running on my PC.

    I've tried everything for the installation-directory.

    What can you do about this??

    greetz,

    Evert

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Are you using an English version of VS? If not, then you should know it's not supported in patch 1... Patch 2 solves this problem.

      By the way - please next time post questions as new posts (this might become a long thread...)

      Regards,

      Ofer

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.