Skip to Content
avatar image
Former Member

Acitvating debugging in developer studio

Hi We are running WAS 640 EP6 SP9 and Developer Studio version Version: 2.0.9

I have read the document on how to activate debugging for our J2EE Application.

We cannot activate debugging, Any ideas, We are running on the Sneak Preview of WAS 640.

Regards

Arun

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • Best Answer
    Jan 25, 2005 at 03:46 PM

    Hello Arun,

    First you have to make the engine debuggable and assign it a port. To do this you have to perform the following steps

    1. Open the configtool by running the configtool.bat under your C:\usr\sap\J2E\JC00\j2ee\configtool directory.

    2. Once the window opens up expand the instance_IDxxx node and click on server. On the right hand panel go to the debug tab

    3. make sure the debuggable check box is checked and a free port is assigned (by default it is 50021).

    4. Restart the server.

    5. Now go to your project and click on the icon debug as.

    6. Pick the kind of project you want to debug and click run. (don't forget to put a breakpoint in your code by double clicking on the first column)

    Regards

    Abdul

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 25, 2005 at 03:44 PM

    Hi Arun

    Right click on the J2EE Engine perspective in NDS and you will get an option to start the Server in Debugging mode. Hope that clarifies your question.

    regards

    Ravi

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 25, 2005 at 03:48 PM

    Hi Arun,

    From many of Detlev's warnings and information, I have come to know that:

    a) Your WAS version and Developer Studio version should be same i.e WAS 6.3007, Developer Studio should 2.0.7 (Someone correct me if I am wrong).

    b) I was trying to activate debugging, and could not do that. Strange problem. Norton AntiVirus Intruder setting was On. I deactivated it. Rebooted my machine again. Now it works like a smooth Porsche(never seen/heard one, but like the simile) :P

    If you can let us know, what all things you did, and still it would not work, the many experts here, would probably help you.

    Regards,

    Subramanian V.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 25, 2005 at 03:51 PM

    Hi Arun

    I guess i misunderstood the problem. Have you activated the server to run in debug mode as per the document.

    if so then go to Run Menu of NDS and select Debug and create a new WebDynpro Configuration.

    There you will need to give a configuration name (some name) and the WebDynpro project and the Application Name in the Debug Tab.

    Go to the J2EE Engine tab and ensure that you dont get a error there. This will give an error if your server is not running in Debugging mode.

    Also ensure that your application has a breakpoint set.You can set the breakpoint in any view or controller as per your requirement.

    Save and then apply those changes and click on Run. Your application should start running in Debugging mode.

    regards

    Ravi

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 25, 2005 at 04:53 PM

    Thanks

    We have activated the debugger.

    Much Appriciated.

    Thanks again for the help and input.

    Regards

    Arun

    Add comment
    10|10000 characters needed characters exceeded