Skip to Content
avatar image
Former Member

SQL error 3113 occurred; work process in reconnect status

The platform is: Windows 2008 R2, Oracle 11.2.0.2, Oracle client 11.2.0.2, SAP NW 7.02, kernel 720 patch 90.

When I try to made an offline backup (or when I stop the database without stopping SAP), one DIALOG work process starts to u2018executeu2019 the program u2018programu2019 <AUTO TASKHANDLER PROCESSING>.

In SM21 I can see the warning u2018SQL error 3113 occurred; work process in reconnect statusu2019 form this work process.

The dev_w, have this information:

C Wed Jul 27 10:25:28 2011

C OCIStmtExecute() failed with -1=OCI_ERROR

C SQL error 3113:

C *** ERROR => Error 3113 in stmt_fetch() from oci_execute_stmt(), orpc=0

C {root-id=68B599B2C0441ED0AE853F7B74750675}_{conn-id=00000000000000000000000000000000}_0

C *** ERROR => ORA-03113 occurred at SQL stmt (parse error offset=0)

C {root-id=68B599B2C0441ED0AE853F7B74750675}_{conn-id=00000000000000000000000000000000}_0

C Dump statement cache:

C sc_p=00000000080EDEF8,no=47,idc_p=000000000935E7B0,con=0,act=1,slen=83,smax=256,#vars=2,stmt=0000000009539EB0,table=SECURITY_CONTEXT

C SELECT * FROM "SECURITY_CONTEXT" WHERE "EOL_TIMESTAMP">:A0 AND "EOL_TIMESTAMP"<:A1 ;

C Dump statement cache:

C sc_p=00000000080EDEF8,no=47,idc_p=000000000935E7B0,con=0,act=1,slen=83,smax=256,#vars=2,stmt=0000000009539EB0,table=SECURITY_CONTEXT

C Dumping DBSL stmt. cache:

C sc=00000000080EDEF8, scp=00000000080F8410, ups_sc=0000000000000000, stp=000000002ED52008, r_c=0

C prep=0, lit=0, nsql=0, lobret_cnt=0, fae_cnt=0, xop=1, dbcnt=0

C IN : col_cnt=2, row_max=1, row_xcnt=0, row_pcnt=0, row_i=0, row_total=0,

C row_upto=-1, row_size=22, vda_max=32, bound=1, itp=000000002E8ABF60, vda_arr=000000002ECD1000

C lob_cnt=0, lob_max=0, lob_pw_cnt=0, lob_arr=0000000000000000, rows_ret=0

C OUT: col_cnt=10, row_max=928, row_xcnt=928, row_pcnt=0, row_i=0, row_total=0,

C row_upto=-1, row_size=114, vda_max=32, bound=1, itp=00000000095428E0, vda_arr=000000002ECD1890

C lob_cnt=0, lob_max=0, lob_pw_cnt=0, lob_arr=0000000000000000, rows_ret=0

C SELECT * FROM "SECURITY_CONTEXT" WHERE "EOL_TIMESTAMP">:A0 AND "EOL_TIMESTAMP"<:A1 ;

B ***LOG BYM=> severe DB error 3113 ; work process in reconnect status

B ***LOG BY4=> sql error 3113 performing FET on table SECURITY_CONTEXT

B ***LOG BY0=> ORA-03113: end-of-file on communication channel

Process ID: 1960

Session ID: 82 Serial number: 9

B dbtran ERROR LOG (hdl_dbsl_error): DbSl 'FET'

B RSLT: {dbsl=99, tran=1}

B FHDR: {tab='SECURITY_CONTEXT', fcode=225, mode=2, bpb=0, dbcnt=0, crsr=1,

B hold=0, keep=0, xfer=0, pkg=0, upto=0, init:b=0,

B init:p=0000000000000000, init:#=0, wa:p=0X000000000202ED00, wa:#=148}

B dbtran ERROR LOG (hdl_dbsl_error): DbSl 'FET'

B STMT:

B CRSR: {tab='SECURITY_CONTEXT', id=1, hold=0, prop=0x10000, max.in@0=0, fae:blk=0,

B con:id=0, con:vndr=5, val=2,

B key:#=2, xfer=0, xin:#=0, row:#=0, upto=0, wa:p=0X000000000202ED00}

C *** ERROR => DbSlExeRead: missing private_ptr in descriptor area

C {root-id=68B599B2C0441ED0AE853F7B74750675}_{conn-id=00000000000000000000000000000000}_0

*B ***LOG BYK=> current SQL statement exceeds a database limit *

B dbtran ERROR LOG (hdl_dbsl_error): DbSl 'FET'

B RSLT: {dbsl=2, tran=16384}

B FHDR: {tab='SECURITY_CONTEXT', fcode=225, mode=2, bpb=0, dbcnt=0, crsr=1,

B hold=0, keep=0, xfer=0, pkg=0, upto=0, init:b=0,

B init:p=0000000000000000, init:#=0, wa:p=0X000000000202ED00, wa:#=148}

B dbtran ERROR LOG (hdl_dbsl_error): DbSl 'FET'

B STMT:

B CRSR: {tab='SECURITY_CONTEXT', id=1, hold=0, prop=0x10000, max.in@0=0, fae:blk=0,

B con:id=0, con:vndr=5, val=2,

B key:#=2, xfer=0, xin:#=0, row:#=0, upto=0, wa:p=0X000000000202ED00}

*C *** ERROR => DbSlExeRead: missing private_ptr in descriptor area*

C {root-id=68B599B2C0441ED0AE853F7B74750675}_{conn-id=00000000000000000000000000000000}_0

The last section is repeated continuously and the file trace grows quickly until the disk is full.

Iu2019ve tried to change the kernel version and to reduce the number of work processes, but the problem continues.

There aren't dumps.

I can't find a solution in SAP notes.

Any idea?

Enrique Rodríguez

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Jul 27, 2011 at 01:41 PM

    You may have external systems trying to connect (BW, CRM, Portal etc.) trying to read somethign from the database which doesn't work because the database is not up.

    You can't prevent those errors if you shut down the database while the system stays up.

    Markus

    Add comment
    10|10000 characters needed characters exceeded

    • > The note is not relevant because there is not active the HTTP security session management in the SAP system. I chequed it in transaction SICF_SESSIONS (Note 1322944 - ABAP: HTTP security session management)

      > In the system isn't users connected actually.

      Yes - but apparently a kernel internal process tries to find out whether there are connections (by executing the sql statement you posted earlier) every minute - that's why I assumed that this is the cause of the error you see (not the solution though).

      If you don't use HTTP you can try to deactivate ICM alltogether and see if the error persists.

      The handling/cleaning up can have been introduced with the new release if that problem didn't happen before.

      Just guessing here and trying to help 😊

      Markus

  • avatar image
    Former Member
    Aug 15, 2011 at 08:56 PM

    Enrique,

    Did you ever find a solution for this? We have been having the same issue since we upgraded to ERP EhP5.

    Carol.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      Yes, a reply today from OSS :

      The problem will be corrected in the coming 7.20 kernel with patch number 106. It will be available by end of this week, but the is no guaranty.

      Another solution for prevent icreasing file is to disable tracing for the duration of the offline backup, see note 495911.

      respect to transaction SM50 (ignore the part regarding SM19 / SM20) - but instead of setting the trace level to 2, set it to value 0

      Regards,

      Patrice

  • avatar image
    Former Member
    Oct 11, 2011 at 09:40 AM

    Hi,

    The problem is solved with patch dw_106-10007272.sar.

    No message filling trace file any more.

    😉

    Regards,

    Patrice

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 02, 2016 at 01:07 PM

    This message was moderated.

    Add comment
    10|10000 characters needed characters exceeded