Skip to Content
author's profile photo Former Member
Former Member

BPS Web Interface Builder

I am having trouble getting my Area...Layout into the WIB without a syntax error. This was working great a few days back, but something has happened and I can't save. I have a simple layout with only one characteristic in the Lead Column, but here is the error msg I receive in a pop up display box:

Check component 'Layout 1' Message No. UPWB098

Rows cannot be inserted, the layout contains complex lead columns Message No. UPWB161

Thanks for any ideas. Keith Johnson

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 24, 2005 at 02:58 PM

    Gerd,

    Thanks. My layout is set to "Key Figures in lead columns, rows individually defined".

    I have looked in the WIB and can't find what you are referring to about having the settings switched on for new rows and input help. So I can't give you an answer. You are not talking about the selections when you place into a Planning Folder are you?? Besides, you don't have to have a Planning Folder to be able to publish to the web, correct??

    Thanks for your help. Keith Johnson

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello Keith,

      Have a look at the properties of the sub-component "layout" in the web interface builder (double click on the layout in the tree of the web interface, then have a look at the lower tree). There are some settings for new rows, such as "Pushbutton for new rows" or "Input help for new rows". But as there are no new rows possible you have to make sure that the settings for these attributes match your situation , i.e. "Pushbuttons for new rows" has to be set to "false", "Input help for new rows" has to be empty etc.

      You do not need a planning folder for any of that...

      Best regards,

      Gerd

  • Posted on Jan 24, 2005 at 01:19 PM

    Hello Keith,

    I think s.o has changed the layout in the layout builder. Now on the first screen of the layout builder the type of the layout is set to "keyfigures in lead columns" or "keyfigures in lead columns, rows individually defined". In both cases the structure of the key column is fixed and you cannot insert new rows into the layout. What I presume is that in the Web interface builder you still have switched on the settings for new rows and input help. Can you check that please?

    Best regards,

    Gerd Schoeffl,

    SAPNetWeaver RIG EMEA

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 24, 2005 at 04:03 PM

    Gerd,

    That took care of my syntax check. Thanks for your help.

    Keith Johnson

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.