Skip to Content
author's profile photo Former Member
Former Member

8.5 x 5.5 paper size in VS2010 with Basic Crystal report

Hi,

Looked everywhere for this issue; but found answers related to CR2008 version, I am struck with VS2010 with basic Crystal Report having issue with paper Width Greater than Height.

Crystal report automatically change orientation of Paper to Landscape if Width of Paper is Greater than Height, any solution to this ? at least any work around ?

Thanks

Vinod Tulsiani

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Best Answer
    Posted on Jul 26, 2011 at 03:29 PM

    Search in hear also, create a custom Printer with the paper size and orientation set up properly and then check on the option to Dissociate... in the report.

    Also make sure the printer driver and printer you are using supports MS .NET Framework.

    Don

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 27, 2011 at 08:18 AM

    Thanks for your reply,

    I am using Samsung ML-1610 Printer; I tried setting Paper size 6 X 6 and it works fine as soon as I set paper size as 8.5 X 6, print gets auto rotate to Landscpae mode.

    Vinod

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 27, 2011 at 02:42 PM

    Thanks for taking keen interest in my problem,

    Dissociate Page Size option is Selected (Checked).

    In code I only select Printer using below code.

    rptGatePass.PrintOptions.PrinterName = Properties.Settings.Default.SlipPrinter;

    If I select 6 X 8.5 it prints correctly in Portrait.

    The problem begins when I set Width Greater than Height.

    Vinod

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi All,

      Thanks for waiting. I have the info now...

      It is fixed in CR 2008 as well.

      This should work also for CR for VS 2010 now, SP is not required, add this key to your PC's:

      [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Crystal Reports\DesignerOptions]

      "DealWithMinimalMarginsWhenPrinting"="0"

      Key=0 => minimal margins

      Key=1 or delete key => large margins

      As well here the sample code and note the PrintToPrinter does NOT read this key, you must use RAS:

      For Winform Viewer, it will not impacted this fix... in CR.Net SDK, if user used reportdocument print function like:
      
      reportDocument.PrintOptions.DissociatePageSizeAndPrinterPaperSize = true;
      reportDocument.PrintToPrinter(1, true, 1, 1); 
       or they tried to print via CrystalReport Winform Viewer
                  reportDocument.PrintOptions.DissociatePageSizeAndPrinterPaperSize = true;
                  this.crystalReportViewer1.ReportSource = reportDocument;
                  this.crystalReportViewer1.PrintReport();
      
      Even by setting the following registry key to u201C0u201D, the print out page will be large margin.
      [HKEY_LOCAL_MACHINE\SOFTWARE\Business Objects\Suite 12.0\Crystal Reports\DesignerOptions]
      "DealWithMinimalMarginsWhenPrinting"="0"
      
      
      However if you using RAS.Net SDK to print like following code, it will be affected by the fix:
                  ReportDocument reportDocument = new ReportDocument();
                  reportDocument.Load(@"C:\Users\Administrator\Documents\Visual Studio 2008\Projects\CrystalReportsApplication1\CrystalReportsApplication1\CrystalReport1.rpt");
                  reportDocument.PrintOptions.DissociatePageSizeAndPrinterPaperSize = true; // Please note that, this code is does nothing. The only impacting to print result is the registry key.
                  CrystalDecisions.ReportAppServer.Controllers.PrintReportOptions printReportOptions = new CrystalDecisions.ReportAppServer.Controllers.PrintReportOptions();
                  printReportOptions.AddPrinterPageRange(1, 1);
                  printReportOptions.PaperSize = CrystalDecisions.ReportAppServer.ReportDefModel.CrPaperSizeEnum.crPaperSizePaperA4;
                  printReportOptions.PrinterName = @"\\CNPVGL002\CN64_BW";
                  CrystalDecisions.ReportAppServer.ClientDoc.ISCDReportClientDocument rptClientDoc = reportDocument.ReportClientDocument;
                  rptClientDoc.PrintOutputController.PrintReport(printReportOptions);
      
      
      

      Thank you

      Don

  • author's profile photo Former Member
    Former Member
    Posted on Sep 06, 2011 at 05:37 AM

    Thanks Don for reasearching on the issue and helping out me; till now I have not used RAS.NET SDK, I will definately explore and look into this.

    Hope someday SAP will fix this issue in CR.NET SDK also.

    As I am new to this forum, is there anyway I can award points without marking the issue been resolved ?

    Thanks very much

    Vinod

    Edited by: stcindia on Sep 6, 2011 7:37 AM

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Vinod,

      The Engine is only there because we had a simplified version that was packaged in and for Visual Studio. It was limited and has always been limited and no patches were ever done to it, other than SP1. RAS is the preferred report engine and now that you have it in CR for VS 2010 use it always, you can still use both Engine and RAS in your app.

      So there are a lot of things that are fixed in RAS but will never be fixed in the Engine, just the way it is. CR Basic ( Engine ) was set up as a free product and to get more control the upgrade option was to move to a full build of Crystal Reports to get RAS and resolve any issues.

      So for now your only option is to use RAS...

      It's like the RDC, has Report Creation API's available also...

      Thanks again

      Don

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.