Skip to Content

Migrate from VC 7.11 to 7.3 error while executing service

Hi there,

I want to migrate my VC 7.11 app to VC 7.3. So I exported my model in VC 7.11 and imported it in VC 7.3. So far so good.

Everything seems to be ok so I deployed it to the NW 7.3 server.

When I run the application and execute a service to get some data via RFC from our ERP system everything is ok too.

But when I pass parameters while executing the service, an error occurs.

Error Occurred while executing the service: while trying to invoke the method com.sap.mdi.ObjectFactory.getRfm(java.lang.String) of an object loaded from field com.sapportals.connectors.SAPCFConnector3.metadata.functions.SAPFunctionParameter.of of an object loaded from local variable 'this'

The error only appears when I pass parameters. Without input parameters everything is ok. It tried it with different bapi rfc calls. All with the same result: Without an input parameter there is no problem and with a parameter the error occurs.

Any help with this issue would be greatly appreciated.

Regards, Bernd

Edited by: Bernd Speckmann on Jul 27, 2011 12:22 PM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Aug 01, 2011 at 07:48 AM

    Hi,

    1. Does this occur when running every RFC/BAPI? As far as I understand your message it occurs for more than 1, right?

    2. What are the data types of the input fields?

    Regards

    Anja

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Bernd Speckmann

      Hi Bernd,

      I couldn't reproduce the mentioned problem on our local systems, everything works fine.

      Could you please open a support ticket and provide:

      1. SP and patch level of the source and target systems.

      2. Attach the simplified model that reproduces the problem.

      Regards,

      Mark