Skip to Content
author's profile photo Former Member
Former Member

BAPI error while extending material master u2013 M3821

Dear colleagues,

We extend some materials through BAPI_MATERIAL_SAVEDATA. But sometimes system issues an error message u201CM3821 - Tables TCURM and T001K inconsistent; notify your systems administratoru201D. If I manually try to do it through MM01 it does not show any error.

I have checked tables T001W and T001K there seems to be no mistake! Also all plants are allocated to a company code via customizing and the valuation level is set at plant level.

We are on ECC 6.0 with SAPKH60405 and I have already checked 4 SAP notes (3128 u2013 137601 u2013 864226 u2013 1098062) related with this error but none of them are applicable to our system.

Thanks in advance

Melih

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Aug 10, 2011 at 08:18 AM

    Hi,

    The issue was with coding.

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 25, 2011 at 12:37 PM

    Hello Melih,

    The error can be raised because of inconsistencies in different tables.It can also because of the valuation area missing in table T001W as described in note 70480. So please check that.

    In general message M3821 is rasied if the tables TCURM and T001K are inconsistent.Eg if Your Valuation is at company code level. However, inconsistencies have arisen because of the way in which the company code was configured in

    Customizing or because plants have not been assigned to a company code.

    So you need to check for inconsistencies in:

    table T001, and

    Check the assignment of plants to company code. - OX18

    Check the configuration of the valuation level. - OX14

    If the assignments are correct, check the entries in table T001W. -

    SM31

    Also please can you check the following in your system:

    Goto SE16 -> table T130F

    Please see the following lines and correct them accordingly to the

    standard:

    our standard system: (relea

    FNAME PSTAT

    RMMG1-BUKRS

    RMMG1-WERKS DEVALQPSZXFGB

    So please make sure the fields have the correct maintainance status.

    Hope this helps

    Thanks Amber

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Amber,

      I have checked as you suggest and;

      Valuation level is set at plant level in OX14 and all plants are allocated to a company code in OX18.

      In table T001W no valuation area is missing with respect to plant.

      In table TCURM valuation area is 1 (Valuation area = plant) and in table T001K all valuation areas are allocated to a company code.

      In table T130F entries are same as your suggestion, i.e;

      FNAME PSTAT

      RMMG1-BUKRS

      RMMG1-WERKS DEVALQPSZXFGB

      PS. There is one question I would like ask, in table T001 what I need to check?

      Thanks

      Melih

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.