Skip to Content
author's profile photo Former Member
Former Member

Wrong digital signature for Add-on

I have just upgraded to 2004 (patch 5). My Add-on is installed (finally) and is successfully loading (finally)when SAP B1 is launched. Whenever I re-compile my Add-on for development and replace my Add-on exe I get the error "Wrong digital signature for Add-on" when SAP goes to load the Add-on again.

I cannot successfully create my .ard file without a digital signature for the Add-on .exe (even though the documentation says it is optional).

How can I test my Add-on in development mode if I have to re-create the .ard file and re-install the Add-on everytime I re-compile?? This does not seem correct.

Please advise. Thanks.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jan 18, 2005 at 09:39 PM

    I found a solution to this problem.

    We were not debugging in development mode properly.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.