Skip to Content

internationalization of wd app?

hi,

i followed the instructions in tutorial 16 (Internationalization of WD applications), that means, i've created 2 additional .xlf-files for each View & Controller. now i have:

MyView.wdview.xlf

MyView.wdview_de.xlf

MyView.wdview_en.xlf

MyView.wdcontroller.xlf

MyView.wdcontroller_de.xlf

MyView.wdcontroller_en.xlf

with the propriate source language.

But when I start the application, i only get the values of the xlf-files without the country-codes displayed.

I'm using two users for testing purposes, one with default language "de" & one with "en" & i've set the application to authenticate the users.

At the UI-element from type "date" I can see, that the default language is recognized, because the "de" user sees the format "12.01.2004" and the "en"-user sees "01/12/2004".

why aren't the localized .xlf-files used for the ui-labels/texts?

do i have to localize <b>every</b> xlf-file or just the ones i need to get this thing working?

kr, achim

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 18, 2005 at 08:07 PM

    Hi,

    Sap help state that "if a language is specified in the browser settings of the users,then the application is displayed in this language". So, check that in your browser settings language is not set.

    In order to do it do the following:

    In Internet Exlorer go to Menu -> Tools->Internet Options->Languages and remove any preset languages.

    Hope it helps.

    Victor

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 19, 2005 at 03:49 AM

    Hi Achim,

    The language setting of the browser determines which xlf file would be picked up(It can be done as Victor as mentioned).The language that u have specified at the top has the highest priority and hence the xlf file with corresponding language extension would be picked up.

    Since you are able to see the default values it seems like ur browser language is english(which i think is the default if no language is selected).If you set the value to German(de) you should be able to see the labels/texts in German.

    Hope this helps.

    Regards,

    Sulakshana.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 19, 2005 at 07:24 AM

    Hi,

    At runtime the Language specific text information is determined by session locale, that is specified for the current user by User management Engine.The sequence is

    1. In case of Authenticated user ,the locale specified for this user is returned.

    2. Otherwise locale specified by browser settings is returned if existing.

    3. Otherwise default locale specified in application properties is returned if existing.

    4. Otherwise default locale specified in Web dynpro system properties is returned if existing.

    5.otherwise default locale of the VM is returned..

    So in your case add the german language(de) in your browser settings and set it as the top priority one as said by sulakshana..

    Regards,

    Perumal kanthan.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Achim Hauck

      Check whether the application was generated successfully

      (open up the .ear file with winzip and do the same with the enclosed .wda file). Check for the generated resource bundles as .properties files if they are there and if the content is ok

      Regards

      Bruno

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.