Skip to Content
author's profile photo Former Member
Former Member

MII JRA Connection to ECC Message Server

Hello,

I'm trying to establish a connection between MII 12.0/NW 7.0 and our new ECC system using the JRA Connector.

In the past we've used a JCo connection to call function modules in SAP R/3. We're currently upgrading our R/3 system to ECC 6 and would like to take advantage of load balancing, which JCo doesn't support.

Currently, I have deployed the sapjra.rar file with the following parameters,

MessageServer = ascsECQ.idexxi.com

SystemID = ECQ

Group = PUBLIC

Language = EN

UserName = miirfc

Password = ******

I have also set Auth Type to "Caller Impersonation."

In the workbench, I'm trying to use the JRA Start Session and JRA Function Call action blocks. I have configured the Start Session action block to use the appropriate "sharable" JRA Connector. When I go into the Function Call action block configuration and click the "Get List" button to get a list of Function Modules from ECC, I get an error,

JRAProxy error: Entry not found

I also notice in the NetWeaver logs that I get this error information,

JCO Proxy Error (handleList): Couldn't create ManagedConnection with . {jco.client.lang=EN, jco.client.passwd=****, jco.client.user=miirfc, jco.client.jra_conn=true, jco.client.mshost=ascsECQ.idexxi.com, jco.client.type=B, jco.client.group=PUBLIC, jco.client.r3name=ECQ}

The only thing I see wrong with this, is according to the SAP API for the JCo class, the value for jco.client.type should be "3" for R/3. But I don't know how to set that value or even if that's what's causing the problem.

I have also tried entering username and password information in the Start Session action block and checking the "Use Local Settings" check box but it still gives the same error.

Sorry for the lengthy post, any help would be appreciated.

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Jul 24, 2013 at 11:43 PM

    Nick,

    This Help document link mentions the necessary configuration parameters in the paragraph at the bottom:

    http://help.sap.com/saphelp_erp2005/helpdata/en/2d/c60242e5216324e10000000a1550b0/content.htm

    Hope this helps,

    Sam

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Nick,

      Basis Team can fix your JCO proxy error issue .

      They will set right credential between JCO connectivity & R/3. Both should be same .

      i have faced similar problem and it was fixed by BASIS team.

      Regards,

      Annamalai.

  • author's profile photo Former Member
    Former Member
    Posted on Sep 10, 2013 at 06:15 AM
    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.