Skip to Content
author's profile photo Former Member
Former Member

Automatic Creation of Equipment Master

Hi Experts

I have gone through lot of discussion available on forum but still Asset Equipment link is not working.

I would like to create Equipment when I create Asset.

I have done below settings.

1) Asset Accounting --> Master Data --> Automatic Creation of Equipment Master -> Specify Conditions for Synchronization of Master Data

here i have assigned equipment category and object type and selected direct synchronization after saving in Create Equipment

2) Asset Accounting --> Master Data --> Automatic Creation of Equipment Master -> Assign Master Data Fields of Assets and Equipment

here i have assigned fields here.

When I create asset and save its only creating assets and even not getting error message . I have also checked screen layout and equipment is optional and not seems to be a problem.

To see whether synchronization functionality works I have done settings from Equipment to Asset creation and it's working but that's not the requirement.

I have changed the settings back to the 1) above to create equipment when asset is being created and it's not working.

So to summaries when I create Asset - No equipment is created but if i change settings other way then asset is getting created from equipment.

My question is what settings are missing to create Equipment when I create Assets?

Is there any settings required from equipment side? any specific requirement on equipment category and object type?

Thank you.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jul 20, 2011 at 03:00 PM

    Hi,

    can you see equipment group box in AS03?

    Regards,

    Sayujya

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      Simple,

      1. Go to AOLK and check which tab layout is assigned to your asset class, to transaction group 'Others'.

      2. Go to AOLA select layout you found out at 1st step, then double click on 'Tab Page Titles'.

      3. Select tab page Allocations and click on position group on tab pages.

      4. Click on new entries and insert 'S0013', save.

      after doing this you will be able to find 'equipment' box under allocation.

      and regarding asset synchronization..

      Asset Accounting --> Master Data --> Automatic Creation of Equipment Master -> Specify Conditions for Synchronization of Master Data

      In this step, under the box 'Edit Asset Master Record' mention,

      Create Equipment 2 Direct Synchronization after saving

      Change Equipment 2 Direct Synchronization after saving

      Make sure you do not have any other field 'required' in equipment creation and not assigned to asset field.

      After doing this you should be able to get equipment created automatically..

      Regards,

      Sayujya

  • author's profile photo Former Member
    Former Member
    Posted on Jul 21, 2011 at 12:38 PM

    Thanks Sayujya

    This problem is fixed now. I did change the layout and did eveything I suppose to do before acutally raising question on forum.

    I was testing on best practise templates available from SAP. Screen layout was from best practise and I was changing best practise layout and that wasn't working. But when I changed screen layout to standard SAP layout problem fixed. System works as expected and created equipment from asset and you can also see in master data under allocation tab.

    There is something missing in the best practise screen layout behind the scene which doesn't work evenafter changing the settings. Standard SAP layout works and there is still problem with best practise layout.

    Many thanks guys for alll the support.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.