Skip to Content

User decision step agent issue

Hi All

In my WF I get a user profile back from a method that check a ZTABLE for the correct user to receive mail and a user decision work item .

The mail step is working correctly and sending mail to the user (as per the parameter returned from the method)

The problem is that user decision step does not sent a workitem to the correct user .

Any ideas on what the problem might be ?

In the email step I bind to &ADDRESSSTRINGS&.Not sure what the correct binding is for the user decision step?

Many thks

Gerhard

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Posted on Jul 20, 2011 at 08:08 AM

    Hi,

    If you only have the email address you can use that in the send mail step type, choose recipient type U in the mail tab of that step.

    Kind regards, Rob Dielemans

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 20, 2011 at 08:52 AM

    Hello,

    Look in the definition of the user decision step, there you define which agent receives the workitem.

    How is it defined? Who is it going to now? Look in the log (SWI1).

    Most common problem is missing out the 'US' in front of a username. That and not setting the task to General Task.

    regards

    Rick Bakker

    hanabi technology

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Gerhard,

      you can also test first with a literal.

      So you use the data you are expecting explcitly int he workflow step (e.g. USMYUSER)

      If this works, then you know that the problem is that somehow your container doesnt have the data and then you can focus on that part to solve your problem.

      Kind regards, Rob Dielemans

  • Posted on Jul 20, 2011 at 09:50 AM

    Also what are the values of the agent assignment of the user decision.

    Click the step in the workflow builder and then the yellow button in the toolbar.

    Kind regards, Rob Dielemans

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 20, 2011 at 12:27 PM

    Thank you guys

    I concatenated 'US' with the container element and this solved the prob

    Many thanks again!

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.