Skip to Content
author's profile photo Former Member
Former Member

Import XSD in XI 3.0 - How to?

Hi

I have a question regarding import of an XSD in XI 3.0. The case is that I would like to import an XSD as an "External Definition" but the XSD has references to other XSD's and when I import the top level XSD, XI ignores the references and makes the "External Definition" useless.

Do I have to build my own XSD by copping parts from all the XSD's involved in defining the XML structure or is there away to do this in XI that I have not yet seen?

I tried to import the structure into XMLSPY and it worked beautifully. There I am able to drill down the different levels of the XML structure and to see data element definitions. Should XI not work the same way?

The top level XSD is located at: http://rep.oio.dk/ubl/xml/schemas/0p71/pie/pieLax.xsd

Regards

Christian

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 17, 2005 at 04:22 PM

    Hi Christian,

    the Integration Repository is able to deal with schemas distributed over several files. You do not have to join them manually to one big file. However, you have to load each of them as an External Definition.

    The Integration Repository then will be able to glue the documents together if you have maintained the 'source'-field of the External Definitions (and put everything in one namespace).

    In your example you would not only need to define an External Definition representing the url you mentioned but one more where you load up the document found at http://rep.oio.dk/ubl/xml/schemas/0p71/maindoc/Invoice.xsd

    Moreover, you have to enter this url as 'source' of the second External Definition. As this document again seems to refer other documents you will also have to define External Definitions for them.

    I think this is also described in the Online-Help for External Definitions.

    Greetings

    Stephan

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Christian,

      I assume that you have tried to use the element 'Invoice' in namespacehttp://rep.oio.dk/ubl/xml/schemas/0p71/maindoc/.

      This is based on the type 'InvoiceType' which is a complexType defined as a restriction of another type. This xsd-schema construct is currently not supported. As a workaround I recommend to delete the two tags <complexContent> and <restriction> in the schema.

      I did not look through the schemas, so there may be more constructs that are currently not supported.

      It is planned to extend the capabilities of schema understanding in the future, but I am not in the position to make any announcements here.

      Regarding namespaces: The namespace of the External Definition is totally independent from the namespace of the documents imported. It is just a mean to provide uniqueness of names of repository objects. For External Definitions it also serves as boundary for the visibility of this special linking mechanism via the source-field. As far as I know there are no plans to change this.

      Indeed, I see no urgent need for this, as you can upload documents from different namespaces as External Definitions in one repository namespace.

  • author's profile photo Former Member
    Former Member
    Posted on Jan 17, 2005 at 03:49 PM

    Hi,

    You should try to import the root node level XSD and not the top level XSD..check in your XMLSPY which is your root node and click on that when you try to import into XI..It works beautifully....

    Hope it helps..

    -Teresa

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.