Skip to Content

Change language display in C4C

Hi All,

I have a user in Russia who, when they login to C4C in a browser, all text is in Russian.

We tried to go to Personalize --> My Settings and change the Regional language to English but when we saved and closed, logged out and back in again, everything was still in Russian.

Where do we go to change it so that our user can change it to, say English language?

Thanks in advance

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    Dec 16, 2016 at 02:08 PM

    Hello Sandico

    No language selection is offered when user certificates or SSO are used for authentication. The first supported language specified by the browser client is used. If you have not specified a preferred language in your browser or if all preferred languages specified in your browser are not supported, then the language configured in the user settings in C4C system is used as logon language.

    Examples:

    A) You are using Internet Explorer and have configured ONLY Vietnamese language in “Tools => Internet Options => General => Languages” and in C4C system you have defined Portuguese in “Personalize => My Settings => Language”.

    What will be C4C ByD language after logging on automatically to the system?
    Portuguese

    Why?
    Portuguese will be the system language because C4C system takes into account the language configured under “Personalize=> My Settings” view when the preferred language defined in your browser is NOT supported – in this case Vietnamese.

    Hope this clarifies your request. Feel free to set the answer as correct.

    Best Regards

    Gabriel Brage

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 16, 2016 at 06:47 AM

    Hi,

    You can change the language while logging in to C4C at Log-on Page.

    Thanks

    Saurabh

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 16, 2016 at 01:54 PM

    Hi Saurabh,

    We use single sign on so the user does not get to the login page, it logs them directly in. Where else can they change it?

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 16, 2016 at 03:04 PM

    Thanks Gabriel, i will test with my user (she's in Russia! but wants to use English) and will get back to you.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 19, 2016 at 02:35 PM

    Worked perfectly thanks!

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 09, 2017 at 08:09 AM

    Hi Gabriel,

    I have a similar issue. We use SSO. When I use Internet Explorer the interface language is English. But when I use Chrome, it is Russian.

    Chrome interface is English. In Chrome settings I deleted Russian and kept only English. In C4C settings I have language defined as English.
    I tried to relog-in to MS account and reopen Chrome - didn't help.

    Do you have any ideas, why when I open C4C in Chrome I still see Russian interface?

    BR,
    Yuri

    Add comment
    10|10000 characters needed characters exceeded