Skip to Content

Can not produce Target Element

Hi,

we have a jdbc to idoc scenario, the messages are failed in sxi_monitor with can not produce target element.

please advise how to resolve this issue.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jul 16, 2011 at 06:20 PM

    Check your mapping under the Message Mapping->Test tab.

    Check if you mapped all the mandatory Fields.

    Srini

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 16, 2011 at 06:28 PM

    In Message apping editor test tab set test mode as DEBUG and test the message mapping.

    Then you can see exactly in which field it is failing.

    Then check the mapping for that field.

    It may be the due valus missing in QUEUE context.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 16, 2011 at 08:44 PM

    This is basically mapping exception due to missing data for the mandatory target elements. Make sure from idoc mappng passes value to all target mapping elements. Copy the sxmb_moni payload data and paste in the mapping tool and debug field by field.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 17, 2011 at 03:09 AM

    Hi KESAVA123,

    If you have not mapped mandatory fields you will get a red circular symbol in target field. If you are not seeing anything red then you have mapped them alright. Now please check minimum occurence of the target fields.If you find min occuerence is zero then check the logic of mapping, when you produce the target element. I feel somewhere you are required to use creatif function which is missing.

    regards

    Anupam

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 17, 2011 at 06:36 AM

    Hi,

    In which pipeline step your messages are failing in SXI_MONITOR.

    In Integration directory we can test the configuration whether all the pipeline steps are working fine or not. To test the configuration

    To call the configuration test, in the Integration Builder main menu (Integration Directory), choose Tools --> Test Configuration, This function enables you to simulate the processing of a message on the basis of the existing configuration data.

    Enter all the parameter and the test source XML, start the test configuration. This will let us know where exactly is the error in the pipeline steps.

    If the error is in Message mapping, try to trace out the error in Message mapping test tool.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.