Skip to Content
author's profile photo Former Member
Former Member

batch program step not picking up files

I have an issue where there is program that is the only step in a batch job. This program should pick up files in a named directory (i.e. /usr/sap/DYNA/outfile/new) and process them.

The issue is that the batch job is not failing but it also is returning a message of "Processing finished. 0 Successful. 0 Failed"

In AL11 I can see there are 3 files ready to be processed.

The user running the job has access to the file path in s_dataset and no changes have been made to the program.

I tried running it myself(since I have super user access) and i get the same result.

I am basically a security person but am posting this in the abap forum since I have checked all the security and it looks ok.

Does anyone have any suggestions on where to go next?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jul 15, 2011 at 05:40 AM

    Bobbi,

    If I understand your concern well, you are getting an message 0 success 0 fail though no processing is being done.

    It is the issue of program logic and might have nothing to do with security/auth. The program is not well coded to catch the errors, messages well and hence wrong message is issued up.

    Please check with an ABAP guy to find the root cause.

    Regards,

    Diwakar

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Bobbi,

      there is also a 2nd error possible.

      The program may work fine, but it will look for programs e.g. with a special prefix and a running number or date or something else as a suffix.

      Maybe the files you have do not match for this, because the file names are different (case sensitive) or the running number of the files have got a new dimension (one more digit) or something else.

      Regards,

      Klaus

  • Posted on Jul 15, 2011 at 06:22 AM

    Hi,

    1. Check the program is erading the data with correct file name.

    2. is your system is having the multiple aplication servers..? If yes then also check with basis person that is that folder is vaiable on the all the aplication server on not.

    since during the execution the system will pick the application server randomly based on the load, if it is not specified in the job. and if on that application server if file path and fileis not present then it will fail .

    3. Try to put the default application server name in the batch job where the specified folder and files are avaiable.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks for the suggestions..I will run them by the basis team. one thing though, this just started happening and no changes were made to either the program or the batch job so I don't know if the app server would be the issue or not. Will try and see if that works.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.