Skip to Content
author's profile photo Former Member
Former Member

smart style is not effecting in smartforms print preview

Hi All,

i have created my smart style with HELVE font style and i have created paragraph formats for my smart style. And i assigned one of my paragraph format to header data-> standard format.

I have used this smart style in my smart form. But while doing print preview, my smart form output is not effected by the smart style which i have given. Output is displaying in the form of my smart styles-> header data-> standard format's font wise. Not effecting the paragraph formats what i have given in my smart form text editor.

could anyone reply me how to solve this issue.

Thanks in Advance.

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jul 14, 2011 at 08:07 AM

    Hi,

    You need to check if the text node is actually storing the data in your preferred paragraph format. To do so, change the smartform editor for that text node to sapscript editor and see whats is the paragraph type it is showing there. To do that, open the text node, click on the pencil button which is on the left column, just beside the editor window. It will make the editor full screen. Then in the menu bar, Go to --> change editor.

    Once the editor is changed to sapscript editor, check what is the paragraph format it is showing in the left column. If it is incorrect, change it there.

    Cheers,

    Anid

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      You can do one last thing from your side to ensure you are absolutely right. Open your smartstyle and create a paragraph format under paragraph node, with name P1 (for example). Now in P1, keep the font as Helve and save and ACTIVATE.

      Go back to your smartform, open the concerned text node. Select the text in it and from the drop down select P1. If you have not assigned this smartstyle to your form in attribute node, in that case you need to assign this smartstyle to your form (or in the output option tab of the text node) to get the P1 in the drop down.

      Save and activate the smartform. And let us know if it solves your issue.

      Cheers,

      Anid

  • author's profile photo Former Member
    Former Member
    Posted on Jul 14, 2011 at 12:49 PM

    hi vishnusree,

    could u check the smartstyle whether its activated r not .....and also the printer settings ? bcoz i have faced this problem but finally came to know that there is problem with the printer settings.

    regards,

    sandeep reddy.K

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 15, 2011 at 07:55 AM

    please check whether you activated the style of not.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.