Skip to Content
author's profile photo Former Member
Former Member

Interactive Forms: Error with NW Dev. Studio PL 10

Hi,

I'm trying to test the Adobe interactive forms with SAP Web AS 6.40. I installed NW Developer Studio PL 10 yesterday and tried to include a PDF into the Welcome Web Dynpro.

When I try to edit the Adobe Form via the context menu in the hierarchy browser I get an error: "Unable to create part: InteractiveForm1".

I installed PL3 for the Adobe Designer.

Does anybody know whether this could be an error due to a release level or whether I did an error when installing the NW developer studio?

I also installed the Adobe Designer with the ABAP SAPGUI 6.40. Is it possible that there exist some conflicts when using Adobe with ABAP and J2EE?

Or did I do anything wrong with the WebDynpro config?

Many thanks for any hint!

Best regards,

Birgit

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on Jan 12, 2005 at 03:13 PM

    Hello Birgit,

    You need to check a couple of things. Following are the requirement on the machine that you have installed NDS.

    1. Install Adobe Reader 6.0.2

    2. Install the Adobe Components Framework

    3. Modify you Browsers ActiveX security settings to the following.

    For Internet Explorer 6 or later:

    Go to Tools -> Internet Options -> Security. Click on the button Custom Level and mark Enabled for the following items:

    • Download signed ActiveX controls

    • Download unsigned ActiveX controls

    • Initialize and script ActiveX controls not marked as safe

    • Run ActiveX controls and plug-ins

    • Script ActiveX controls marked safe for scripting

    I am assuming that you had the adobe designer option checked when you installed NDS.

    Regards

    Abdul

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Matthias,

      I had an OSS call opened for this error and got a solution that worked at least with my solution of the NetWeaver Developer Studio:

      The IDEInstaller has not installed the Adobe related files properly. In the directory <plugins>\com.sap.ide.webdynpro.adobetemplatedesigner\lib\.. there exists a file "WDAdobeControl.dll".

      This has to be registered.

      For that following steps have to be performed:

      1. Close the NetWeaver Studio.

      2. Open the command prompt.

      3. Type : regsvr32 "C:\......<plugins>\com.sap.ide.webdynpro.adobetemplatedesigner\lib\WDAdobeControl.dll".

      4. Re-open the Studio.

      Best regards,

      Birgit

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.