Skip to Content
avatar image
Former Member

Crystal Reports do not shows data from SAP ECC tables

Hello Experts,

I have an issue which is driving me crazy...

I have installed CR 2008 Enterprise SP4 and SAP integration KIT SP4 (client component). I can connect to our SAP ECC EHP4 system. However when making a report on top of a SAP Table, Crystal reports do not shows any data although the status bar at the moment of refreshing the report shows it is reading data.

We have tested several tables and the behavior is the same (BSIK, S001, T001, ...). Of course these tables show data on TC SE16

Another symptom is that data exploration doesn´t shows data neither:

Field explorer -> Data base fields -> expand a table -> right click on a table field -> browse data

the window that appears doesn't shows any records

Also when we hanging the cursor over a field the tool tip says the lenght of the field is 0, like this

BSIK.BUKRS: String

Company Code

We already tested using Windows XP SP3, windows Vista, Windows 7

Integration KIT has SP4 as well

Any idea on this??

thanks!

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Jul 14, 2011 at 01:19 PM

    Hi,

    - the ABAP Transports have been imported and updated to SP4 level ?

    - did you make use of the Security definition editor ?

    regards

    Ingo

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello,

      Thanks for the quick answer..

      Yes I imported the transport files corresponding to SP4 software

      In fact I used the overwrite flag at the moment of performing the transport. I also read note 1593706 which basically says you need to import the new transport files comming with the sp4 software, but still I have the problem.

      An extra piece of information. I am connecting to an IDES ECC 6 EHP4 which at this moment has this patch level

      SAP_ABA 701 0003 SAPKA70103

      SAP_BASIS 701 0003 SAPKB70103

      transports I imported were:

      R21K900687

      R21K900688

      R21K900689

      R21K900690

      R21K900691

      R21K900732

      I do not use the security editor.

      thank you!

  • avatar image
    Former Member
    Jul 30, 2011 at 05:00 PM

    solved by myself

    Problem is with SP4 of CR 2008, with SP3 there is no problem. The build number of my CR is

    12.3.0.601

    hopes it helps some one

    Edited by: Garduño Azael on Sep 18, 2011 11:18 PM

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 29, 2012 at 09:42 AM

    Hello Experts,

    I am having the same issue - Crystal Reports does not show data in the table from ECC, shows just the headings. Besides, when i am trying to use FM it gives me the following error - 'Database connectivity error - FUNCTION_NOT_SUPPORTED'

    Our system :

    SAP_BASIS 731 0004 SAPKB73104 SAP_ABA 731 0004 SAPKA73104

    Using Crystal Reports 2011 and also tried Crystal Reports 2008 (with Sap Integration Kit).

    Crystal Reports 2008 version- 12.3.0.601

    User is having SAP_ALL.

    We have imported the following transports IN the following order:

    *Open SQL Connectivity transport (K900732.R21 and R900732.R21)

    * Info Set Connectivity transport (K900688.r21 and R900688.r21)

    * Row-level Security Definition transport (K900689.r21 and R900689.r21)

    * Cluster Definition transport (K900690.r21 and R900690.r21)

    * Authentication Helpers transport (K900691.r21 and R900691.r21)

    Please HELP!!! We are stuck...😢

    Add comment
    10|10000 characters needed characters exceeded