Skip to Content
avatar image
Former Member

issues in output window

Hi experts

In my web dynpro application I am having 1 window, I have a view in it say VIEW_MAIN. In VIEW_MAIN I have added to view containers. In the container 1 I have embedded a view with certain input fields and buttons. In container 2 I have embedded another view with some button and an ALV(in container). I have set VIEW_MAIN as the default view but still in output I am getting the ALV only. Why is this happening? How could I see the complete VIEW_MAIN in output?

Thanks in advance

Gaurav

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Jul 12, 2011 at 05:57 AM

    Gaurav,

    Be default you should be able to see all the containers. Please check whether did you embed the view in first container.

    I think you know, how to check..

    window->expand view->select first container then you will get the embedded view container details......if not , embed the view again.

    Regards

    Srinivas

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 12, 2011 at 07:01 AM

    Hi Srinivas,

    I have checked everything already. embedding is correct.

    Thanx

    Gaurav

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 12, 2011 at 07:27 AM

    Every view container is visible and enabled.Checked already.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 12, 2011 at 10:24 AM

    Did you check if that is due the size of ALV being displayed and the other view is just not visible on scree? Did you check if you have a scroll bar...??

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 12, 2011 at 12:53 PM

    Every view container is visible and enabled.Checked already. There is no scroll bar also.The table which is shown is in the 2nd view container of the second view. So it should display the first View before the ALV, but it is not happening. Is it possible by setting some authorizations?

    Add comment
    10|10000 characters needed characters exceeded