Skip to Content
author's profile photo Former Member
Former Member

"program AI_DIRECTORY_<SID> not registered"

Hello.

I'm doing the post-installation steps for XI 3.0. I created the RFC destinations in SM59 and created the RFC destinations in the J2EE's JCo RFC Provider service. When I try to test the RFC connections I get the error in the subject -- "program AI_DIRECTORY_XI0 not registered" (XI0 is the SID) -- I get the same message with different program names for the other RFC destinations.

ABAP is alien to me, and I don't have a basis guy to asisst (this is just a test system for educational purposes). I'd love to get some hint as to what I should be checking -- where can I find out which programs are registered (and how can I register the missing ones)?

Thanks,

Alon.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jan 09, 2005 at 02:17 PM

    Never mind, problem solved. 😊 wrote the wrong program IDs on the J2EE side

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.