Skip to Content
Jul 08, 2011 at 04:34 PM

SUP 2.0 and operation with input table scenario.



I created an mbo in sup 2.0 with an operation that takes as input a table type. The operation is mapped to a remote RFC (but I have also tried to map it to a webservice with the same results).

SUP has self-generated a structure that represents a row in the table, and uses it to power the operation.

During the "test execute" I get the following error: "Execution failed: null" and the rfc is not called on backend (SAP).

I also tried to create a workflow with a listview that displays the elements of the table, and a menu item that performs an "online request" invoking the operation, and passing it the key associated with the listview. In this case the operation is called on the backend, but the table comes completely empty.

So, I tried to do the same thing with a structure in input to the operation rather than a table. Again, SUP generates itself a support structure, but in this case, data are sent to the rfc (using workflow) and the "execute test 'works fine!

Has anyone had the same problem?