Skip to Content
author's profile photo Former Member
Former Member

problem with EDI_DC40

In mapping the source flat file structure to idoc type debmas 03, there is a need to disable the EDI_DC40 field. I did not find any option to disable in SAP XI 2.0 version. Any suggestion??

Thanks in advance.

Sriram

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 10, 2005 at 05:42 AM

    Sriram,

    Can you please explain why you need to disable the EDI_DC40 field ?

    Thanx,

    Homiar.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 11, 2005 at 05:05 AM

    Hi Homiar,

    Thanks for your response. I am using the scenario

    file -xi idoc in SAP XI 2.0. During mapping, the source structure is mapped with idoc structure.

    Regarding EDI_DC fields, i thought those control data will be dynamically filled during runtime. So i wanted to disable the filed EDI_DC40. This option is available in

    sap xi 3.0 and i didnot find any option in SAP XI 2.0.

    Do u have any idea like handle this EDI_DC during mapping??

    Rgds,

    Ramgopal

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Sriram,

      I agree with Paul. Just map the obligatory fields like the Message type etc. SAP XI anyways overwrites at run time the info required by it to process.

      I have never disabled the field in 2.0 like in 3.0, but will investigate & let you know my finding.

      Regards,

      Homiar.

  • Posted on Jan 11, 2005 at 07:02 AM

    Hi,

    I think you can just map al the obligatory fields in the control record, XI will automatically replace the neede control records fields below the surface dependant on your SLD settings and IDX-settings.

    It makes no sense actually but it works!

    Cheers,

    Paul

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.