Skip to Content
avatar image
Former Member

Activate the HTTPS service in SMICM

Hi ,

The below parameter has been set but the HTTPS service in not active in SMICM >GOTO-Service. Can someone help on how to activate the HTTPS service. I tried to activate using service >Activate but it gives an error message as "Operation failed (rc=1)".

icm/server_port_1 = PROT=HTTPS,PORT=44300,EXTBIND=1,TIMEOUT=1800

Regards

Krishnan.G

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Jul 08, 2011 at 09:38 AM

    Hello Mr.

    In RZ10 put:

    icm/host_name_full <pi hostname>

    icm/HTTPS/verify_client 1

    ssl/ssl_lib /usr/sap/<sid>/SYS/exe/run/libsapcrypto.o

    sec/libsapsecu /usr/sap/<sid>/SYS/exe/run/libsapcrypto.o

    ssf/ssfapi_lib /usr/sap/<sid>/SYS/exe/run/libsapcrypto.o

    ssf/name SAPSECULIB

    icm/server_port_4 PROT=HTTPS, PORT=<https portnumber>, TIMEOUT=6000

    Then, in SMICM, activate http service

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      icm/host_name_full <pi hostname>

      icm/HTTPS/verify_client 1

      ssl/ssl_lib /usr/sap/<sid>/SYS/exe/run/libsapcrypto.o

      sec/libsapsecu /usr/sap/<sid>/SYS/exe/run/libsapcrypto.o

      ssf/ssfapi_lib /usr/sap/<sid>/SYS/exe/run/libsapcrypto.o

      ssf/name SAPSECULIB

      icm/server_port_4 PROT=HTTPS, PORT=<https portnumber>, TIMEOUT=6000

      This is a good example from your system which runs on Unix.

      This should not be blindly copied in any system.

      The configuration has to be adapted to each customer need.

      Regards,

      Olivier

  • avatar image
    Former Member
    Jul 08, 2011 at 09:59 AM

    Do remember to download SAPCRYPTO library if its not already there to enable https.

    https://websmp103.sap-ag.de/tcs -> Download Area ->SAP Cryptographic software

    Thanks

    Amit

    Add comment
    10|10000 characters needed characters exceeded