Skip to Content
avatar image
Former Member

How to disable post option in FB50 / F-02

hiiii All

I have some Requirement. My client wants to give Release approval for GL Document in FB50.

I have Created and setting up workflow for level wise release approval for Parked document. In FB50 When i parked document it works fine and parked document goes to Approval SAP Inbox.

But when the user Post the Document in FB50 the document is posted. My requirement is how to disable post option in F-02, FB50? so that user can only park document and doc will goes to approval inbox

please help

Rajesh Mahato

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 08, 2011 at 05:27 AM

    Hi Rajesh,

    You talk to your ABAPer, need some user exit of Standard T.code.

    Thanks & Regards,

    Pradip

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 08, 2011 at 05:45 AM

    Dear:

    This can be achieved through SHD0.. You can disable posting button in these t code using SHD0. Please follow the procedure given as

    Go to SHD0...In t code write FB50...Transaction Variant..ZFB50...Click create ... Now enter document date as soon as you enter document date just press enter ... A new box will appear .. There will a button at its bottom--Menu Function...Click it...A new screen will appear...In it go to menu Bar...document.. There you will see post click on it and press F2..now it will be deactivated..Exit and save..Give Package that ABAP use and save it again and again until it shows that the changes have been saved.. Now you will see this ZFB50 in Standard Variants tab of SHD0.. Activate it.

    Do the same thing for F-02. So you simply have to create Z screen variant and assign them to t code.

    It will do the job for you.

    Refer to the link i posted earlier regarding disabling parking button in FB50

    fb50-disable-park-icon

    Regards

    Add comment
    10|10000 characters needed characters exceeded