Skip to Content
author's profile photo Former Member
Former Member

Error: Response code 302, When accessing Google search API from Webdynpro

I am developing Webdynpro application in which i have provided Google search facility by using Google search API as web service. But when i am executing my application and search for some expression then it gives "Service Call Exception : Invalid Response code 302".

So if anybody can solve this problem then please help me.

Thanks,

Bhavik

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 05, 2005 at 11:11 AM

    Hi Bhavik,

    It seems that you must be making the wrong service call or wrong URI. I would check to see that the target address defined in the wsdl port file is correct (lport1_.lp). I am just guessing since thats what the response code 302 sorta references. To learn more about the response code goto http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html

    Also double check your Google API license if its correct. I was able to successfully create the Google WD app but im facing a 407 response code(my company's proxy) and for some reason i can't define the password in the port file so i can't get around it. If you ever figure it out please let me know.. (wael.aoudi@aramco.com)

    Thanks...

    -wael

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Thats the correct target!! I dont know why you get the 302 response..you must have missed something..cos i didnt get that problem.. but you know maybe after i bypass the proxy (if i ever do) then i will get the same error... have you looked at the Best Practices google tutorial posted on sdn. look for it under Web Dynpro.

      You can access the port file using the package explorer(window/showview/packageexplorer) find your project and expand it. then expand "src/packages" then expand <yourpackagenamespace>.proxies you will find a file called <i><b>lport1_1.lp</b></i>. double click and it will open for editing/modifying. notice there that you can not apply your proxy password.

      Please let me know the exact steps to invoke the password method, do i need to modify the non generated classes?

      Thanks,

      Wael

      I hope this helps !!

  • author's profile photo Former Member
    Former Member
    Posted on Jan 06, 2005 at 04:09 AM

    I have specified my proxy IP and port in that file. I have also specified username. In that same file i have specified Target address as http://api.google.com/search/beta2. I hope this address is correct. Please verify this link in yr application also. For statefull communication i have taken Use HTTP Cookie based sessions. Is it corretct?

    For your paasword problem, u can write following code where u creating Request object and setting yr license key. Before calling setStart() method of request object u need to call _setPassword() method of request object....

    Ok i think it may help u.....

    And also please verify my lport_1.ip file as well.

    Thanks,

    Bhavik

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.