Skip to Content
avatar image
Former Member

SOAP Adapter Error

Hi,Expert:

There is a system error in all soap sender adapter of the PI Develepment system when i use soapui for test:

com.sap.engine.interfaces.messaging.api.exception.MessagingException: com.sap.engine.interfaces.messaging.api.exception.MessagingException: Error transmitting the message over HTTP. Reason: java.net.ConnectException: Connection refused: connect

These scenarios have been working correctly before.But now, I find all the soap sender adapter have this problem.

And i checked the URL and port ,there is no problem.

Expect your reply,thank you!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Jul 05, 2011 at 06:55 AM

    Hi,

    its network issue, plese check with network team.

    your PI system not able to coonect Sourece system.

    regards,

    Raj

    Add comment
    10|10000 characters needed characters exceeded

    • >You mean there is some connection problem between OA and PI system?

      Yes. The errors shows connectivity error. This could be firewall issue or network connectivity issue. Please talk to network guys and see how that helps. Also make sure you use right URL and PI port. sometime port is not enabled by firewall guys, you might see issues.

  • avatar image
    Former Member
    Jul 05, 2011 at 07:09 AM

    re-generate the WSDL and try in SOAP UI.

    -Nikhil Bose

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 05, 2011 at 07:49 AM

    Hi,

    Go through the note #1349125 also [Link1|http://www.sdn.sap.com/irj/scn/weblogs?blog=/pub/wlg/6568] [original link is broken] [original link is broken] [original link is broken];.

    Blog for troubleshooting SOAP adapter [BLOG|http://www.sdn.sap.com/irj/scn/weblogs?blog=/pub/wlg/3865] [original link is broken] [original link is broken] [original link is broken];

    check at your SLD server if the Integration Server PIPELINE url is correct.

    Go to http://<server>:5<sysnumber>00/sld , then Business System, find your INTEGRATION_SERVER_<SID> and check the Pipeline URL parameter.

    Regards,

    Naveen.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 05, 2011 at 08:01 AM

    Hello Mr Yu,

    Look this document:

    http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/8071b1b8-3c5c-2e10-e7af-8cadbc49d711?quicklink=index&overridelayout=true

    Paragraph 9.1.7

    Communication Error when Sending PI Messages from

    Messaging System to Integration Engine or from

    Integration Engine to Messaging System

    Problem

    1. The messaging system of the Advanced Adapter Engine tries to send a

    message to the Integration Engine but fails with a communication error, for

    example:

    For asynchronous call:

    Transmitting the message to endpoint

    http://pwdf6278:50036/sap/xi/engine?type=entry using connection

    Axis_http://sap.com/xi/XI/System failed, due to

    com.sap.engine.interfaces.messaging.api.exception.MessagingException:

    Error transmitting the message over HTTP. Reason:

    java.net.ConnectException: Connection refused: connect.

    For synchronous call:

    Transmitting the message using connection Axis_http://sap.com/xi/XI/System

    failed, due to:

    com.sap.engine.interfaces.messaging.api.exception.MessagingException:

    Error transmitting the message over HTTP. Reason:

    java.net.ConnectException: Connection refused: connect.

    Note the connection prefix is sender adapter type specific (File, JDBC, etc).

    The error message is different if the port cannot be reached at all.

    when the message is successfully transmitted, the following entry is written:

    The message was successfully transmitted to endpoint

    http://pwdf6278:50036/sap/xi/engine?type=entry using

    connection Axis_http://sap.com/xi/XI/System.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 06, 2011 at 12:48 AM

    Hi:

    The problem was found: the http port was modified in the exchange profile.

    Thanks for every one.

    Add comment
    10|10000 characters needed characters exceeded