Skip to Content
0
Former Member
Jul 02, 2011 at 07:42 PM

EHP1 - Installation to PI 7.1 - Error in phase MAIN_NEWBAS/WINSRV_INST_NEW

13 Views

Dear all,

I have running an upgrade from PI 7.1 to PI 7.11 (in other terms, I am installating EHP1 to a PI 7.1 system).

I have an issue in main phase EXECUTION -, phase MAIN_NEWBAS/WINSRV_INST_NEW :

"An error occured during the installation of the SAP service SAPSID_00 :

" Possibly the password for user XXX\SAPServiceSID entered in phase

"INITPUT was wrong. You can reset it by calling 'SAPehpi set stdpar'

"Try to execute SAPSTARTSRV.EXE manually using the following syntax :

M:\usr\sap\SID\DVEBMGS00\exe>sapstartsrv.exe -r -p M:\usr\sap\SID\SYS\profile\SID_DVEBMGS00_hostname -s SID -n 00 -U XXX\SAPServiceSID-P password -e XXX\sidadm

and check if the service SAPSID_00 can be stopped and restarted.

1. I am able to start the command

M:\usr\sap\SID\DVEBMGS00\exe>sapstartsrv.exe -r -p M:\usr\sap\SID\SYS\profile\SID_DVEBMGS00_hostname -s

SID -n 00 -U XXX\SAPServiceSID-P password -e XXX\sidadm

After this command, I can stop and restart the SAPSID_00 windows services without any problem.

2. I cannot start the command SAPehpi set stdpar.

I get this error :

T:\EHPI\SUM\abap\bin>SAPehpi set stdpar

Enter the path of your root directory [T:\EHPI\SUM\abap]:

Root directory =

Waiting for SAP SL-Controller to connect at port number 4240 (CTRL-C to interrupt)...

ERROR: Environment variable 'SAPUP_OPTIONS' does not exist

Any help is very welcome.

Best regards

SAPNetWeaverAdmin