Skip to Content
avatar image
Former Member

JSPM Not working

Hi Expert ,

when i try to launch the JSPM tool from Linux machine . It is giving message waiting for SDT Server to connect .....

Please find below the logs :

Bootstrap Log :-->

<!--LOGHEADER[START]/-->

<! HELP[Manual modification of the header may cause parsing problem!]/ >

<! LOGGINGVERSION[1.5.3.7185 - 630]/ >

<! NAME[/usr/sap/<SID>/JC00/j2ee/JSPM/log/log_2011_06_29_12_27_01/BOOTSTRAP_01.LOG]/ >

<! PATTERN[BOOTSTRAP_01.LOG]/ >

<! FORMATTER[com.sap.tc.logging.ListFormatter]/ >

<! ENCODING[UTF8]/ >

<! LOGHEADER[END]/ >

#1.5#C0000AFA2B140000000000000065A77F0004A6D2322DE470#1309321622041#/System/Server/Upgrade/JSPM##com.sap.sdt.jspm.bootstrap.Bo

otstrap.init(Bootstrap.java:287)#######Thread[main,5,main]##0#0#Info#1#com.sap.sdt.jspm.bootstrap.Bootstrap.init(Bootstrap.jav

a:287)#Java###Starting JSPM bootstrap...##

*SAPJup LOg:-->

*<! LOGHEADER[START]/ >

<! HELP[Manual modification of the header may cause parsing problem!]/ >

<! LOGGINGVERSION[1.5.3.7185 - 630]/ >

<! NAME[/usr/sap/<SID>/JC00/j2ee/JSPM/log/log_2011_06_29_12_27_01/BOOTSTRAP_01.LOG]/ >

<! PATTERN[BOOTSTRAP_01.LOG]/ >

<! FORMATTER[com.sap.tc.logging.ListFormatter]/ >

<! ENCODING[UTF8]/ >

<! LOGHEADER[END]/ >

#1.5#C0000AFA2B140000000000000065A77F0004A6D2322DE470#1309321622041#/System/Server/Upgrade/JSPM##com.sap.sdt.jspm.bootstrap.Bootstrap.init(Bootstrap.java:287)#######Thread[main,5,main]##0#0#Info#1#com.sap.sdt.jspm.bootstrap.Bootstrap.init(Bootstrap.java:287)#Java###Starting JSPM bootstrap...##

Hostname> more SAPJup.LOG

<! LOGHEADER[START]/ >

<! HELP[Manual modification of the header may cause parsing problem!]/ >

<! LOGGINGVERSION[1.5.3.7185 - 630]/ >

<! NAME[/usr/sap/<SID>/JC00/j2ee/JSPM/log/log_2011_06_29_12_27_01/SAPJup.LOG]/ >

<! PATTERN[SAPJup.LOG]/ >

<! FORMATTER[com.sap.tc.logging.ListFormatter]/ >

<! ENCODING[UTF8]/ >

<! LOGHEADER[END]/ >

#1.5#C0000AFA2B1400000000000F01D85F790004A6D2323E5760#1309321623132#/System/Server/Upgrade/Jump##com.sap.sdt.ucp.pce.build.BuilderDirector.extractElements(BuilderDirector.java:132)#######Thread[main,5,main]##0#0#Info#1#com.sap.sdt.ucp.pce.build.Builder Director.extractElements(BuilderDirector.java:132)#Java###Tag with name found.#2#ControlUnit#JSPM# #1.5#C0000AFA2B1400000000001001D85F790004A6D2323ED460#1309321623164#/System/Server/Upgrade/Jump##com.sap.sdt.ucp.pce.build.BuilderDirector.createUnits(BuilderDirector.java:186)#######Thread[main,5,main]##0#0#Info#1#com.sap.sdt.ucp.pce.build.BuilderDirector.createUnits(BuilderDirector.java:186)#Java###Creating control unit .#1#JSPM#

#1.5#C0000AFA2B1400000000001101D85F790004A6D2323F97B0#1309321623214#/System/Server/Upgrade/Jump##com.sap.sdt.ucp.pce.ctrl.ExecutionDialog.showWelcomeDialog(ExecutionDialog.java:421)#######Thread[main,5,main]##0#0#Info#1#com.sap.sdt.ucp.pce.ctrl.ExecutionDialog.showWelcomeDialog(ExecutionDialog.java:421)#Java###Could not process dialog because execution dialogs have been suppressed.#1#JspmWelcomeDialog# #1.5#C0000AFA2B1400000000001201D85F790004A6D2323F97B0#1309321623214#/System/Server/Upgrade/Jump##com.sa.sdt.ucp.pce.ctrl.ActionExecutor.execute(ActionExecutor.java:103)#######Thre[main,5,main##0#0#Info#1#com.sap.sdt.ucp.pce.ctrl.ActionExecutor.execute(ActionExecutor.java:103)#Java###Starting execution of action with name and type .#2#Unit#JSPM#

JSPM Log:

F

actoryManagerConfigurator.configureLibrary(FactoryManagerConfigurator.java:133)#######Thread[main,5,main]##0#0#Info#1#com.sap.

sdt.tools.bootstrap.FactoryManagerConfigurator.configureLibrary(FactoryManagerConfigurator.java:133)#Java###Factory manager has been initialized with code and version .#3#com.sap.sdt.tools.UtilFactoryManager#UNX#0# #1.5#C0000AFA2B1400000000000C01D85F790004A6D2323D8858#1309321623079#/System/Server/Upgrade/JSPM##com.sap.sdt.tools.bootstrap.B ootStrappingConfigurator.configure(BootStrappingConfigurator.java:770)#######Thread[main,5,main]##0#0#Info#1#com.sap.sdt.tools .bootstrap.BootStrappingConfigurator.configure(BootStrappingConfigurator.java:770)#Java###Bootstrapping configuration for

has been completed.#1#UNX#

#1.5#C0000AFA2B1400000000000D01D85F790004A6D2323DE230#1309321623102#/System/Server/Upgrade/JSPM##com.sap.sdt.tools.bootstrap.B

ootStrappingConfigurator.configure(BootStrappingConfigurator.java:824)#######Thread[main,5,main]##0#0#Info#1#com.sap.sdt.tools

.bootstrap.BootStrappingConfigurator.configure(BootStrappingConfigurator.java:824)#Java###Bootstrapping configuration for

has been completed.#1#700#

#1.5#C0000AFA2B1400000000000E01D85F790004A6D2323DE230#1309321623102#/System/Server/Upgrade/JSPM##com.sap.sdt.ucp.bootstrap.Boo

tStrap.run(BootStrap.java:384)#######Thread[main,5,main]##0#0#Info#1#com.sap.sdt.ucp.bootstrap.BootStrap.run(BootStrap.java:38

4)#Java###Bootstrapping has ended.##

Regards,

Kamal

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

11 Answers

  • avatar image
    Former Member
    Jun 29, 2011 at 05:46 AM

    Hi,

    Please make sure that port number 6240 should be free.

    Thanks

    Sunny

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 29, 2011 at 07:13 AM

    Hi ,

    Port 6240 is free

    Regards,

    Kamal

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 29, 2011 at 04:25 PM

    Hi Kamal,

    This error comes due to incorrect java home settings. If you want to launch just JSPM, try with changing JAVA_HOME environment variable setting on screen where you trying to launch JSPM, it should work.

    Let me know in case of any confusion.

    Cheers !!!

    Ashish

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 29, 2011 at 06:10 PM

    Hi Kamal,

    You said: "It is giving message waiting for SDT Server to connect ....."

    Does this mean it also does not give any error and simply keeps waiting for JSPM GUI to startup? If that is the case, can you confirm if you have set the DISPLAY variable correctly? You can try and launch configtool or visual administrator and see if they are opening? If yes, then DISPLAY variable is set.

    Please share the results of this.

    Regards,

    Shitij

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 30, 2011 at 08:33 AM

    Hi Shitij

    yes , Display variable is set . and Visual Admin is getting launched.

    Regards,

    Kamal

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Then try these two things:

      1. Do ps -ef and see if you find any previously hung JSPM process which failed to start earlier and because it is hung, it may not be allowing the new runs to start. See all processes with sidadm and see if you find anything suspicious.

      2. Cleanup your profile directory: In this, remove all profile backups and extra files from this directory and only have the usual start, instance and default profiles. No backups allowed also. I have observed that many times, this has also caused JSPM to not startup.

      Regards,

      Shitij

  • avatar image
    Former Member
    Jul 01, 2011 at 10:14 AM

    Hi Shitij ,

    No Luck this time again . I have checked both the points given above

    I am checking with network team for port 6240...

    Regards,

    Kamal

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Ok. Check the port then.

      By the way, what is your Netweaver version, stack version as well as OS and DB combination?

      How are you starting JSPM and using which user?

      Regards,

      Shitij

  • Jul 02, 2011 at 09:15 AM

    hi kamal

    R u use the sap system in HA( High Availability)?

    Regards

    S

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 04, 2011 at 05:49 AM

    Hi Shitij ,

    Its a Netweaver 7 SP11

    Linux OS and Oracle DB

    <SID>adm user through VNC viewer

    In JSPM Directory --> ./go

    Hi Sriram ,

    Yes Its a HA System and followed the SAP Note 886296 ,941627 and 1491598

    Regards,

    Kamal

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      If it is HA, then can you run the command "hostname" at the OS level and see what hostname it shows currently?

      Sometimes, you need to set the hostname as the virtual hostname and try.

      At os level, run the command: hostname=<virtual_hostname>. If this does not help, set it back to what it was.

      Ya, also, better have a look carefully at the HA notes also.

      Regards,

      Shitij

  • avatar image
    Former Member
    Jul 04, 2011 at 09:40 AM

    Hi Shitij ,

    In Quality JSPM is working . I was comparing the log of my Quality system with DEV system (JSPM System) .

    Found these files are not present in DEV system

    sdtgui.out

    sdtgui.err

    DETECT_SYSTEM_PARAMETERS_01.LOG

    TroubleTicket_01.txt

    OsProc001_01.ERR

    JSPM_MAIN_1_01.LOG

    DIALOG.LOG

    Might there is some issue with configuration. Parallely I have already opened one OSS message for this issue

    Regards,

    Kamal

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Kamal,

      These are all only log files. These are created only when JSPM starts up.

      I guess you did the right thing in creating the OSS message. Let's see what SAP says.

      Regards,

      Shitij

  • avatar image
    Former Member
    Jul 28, 2011 at 12:45 PM

    Hi All,

    I have copied the JSPM directory on local desktop. from there I was able to launch JSPM tool

    as I have updated the JSPm tool. My JSPM issue on Linux machine also got solved

    Regards,

    Kamal

    Add comment
    10|10000 characters needed characters exceeded