Skip to Content
author's profile photo Former Member
Former Member

PB00 Condition Value multiply by 10 in BAPI_PO_CREATE1

Hi Gurus,

I am using Function Module: BAPI_PO_CREATE1

input in PB00 COND_VALUE is multiplied by 10 each time. Is this normal? If no, how to fix?

Ex.

[INPUT]

Parameter: POCOND

ITM_NUMBER = 000001

COND_ST_NO = 001

COND_TYPE = PB00

COND_VALUE = 1.900000000

CHANGE_ID = U

Parameter: POCONDX

ITM_NUMBER = 000001

COND_ST_NO = 001

ITM_NUMBERX = X

COND_TYPE = X

COND_VALUE = X

CHANGE_ID = X

[RETURN]

Parameter: POCOND

ITM_NUMBER = 000001

COND_ST_NO = 001

COND_TYPE = PB00

COND_VALUE = 19.00000000

CHANGE_ID = U

Regards,

Si

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Jun 28, 2011 at 07:02 AM

    what currency did you submit in the PO header?

    Check OSS Note 580225 - Purchasing BAPIs: Conditions and pricing

    for some background

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.