Skip to Content

DI API Error - (Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))

Hi,

Since upgrading to SBO 8.81 PL05 we are randomly receiving this error in DataPro Logic Automator which runs imports into B1 using the DIAPI - (Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))

I have reinstalled the DIAPI on the B1 server and DataPro Logic server multiple times, each time clearing the temp folders and restarting before reinstalling. I have also installed the DIAPI from multiple locations, including re-downloading it in case there was a corruption somewhere. I've also reinstalled DataPro Logic.

At first the error was occurring more often than not, but now it is less frequent, say around 5% of exports return the error.

Does anyone have any idea what the problem might be?

Any help and suggestions are welcome!

Thanks,

Michael

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jun 27, 2011 at 08:11 AM

    Are you by any chance keeping the company connection open constantly? Sometimes this can cause the sort of error you have mentioned.

    Does it happen randomly? On different lines of code? Or is it always happening in the same place?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.