Skip to Content
author's profile photo
Former Member

SSO for a Webdynpro App? (R3)

Hi everybody,

The million dollar question:

I need to implement SSO in my webdynpro app, but I'm totally losted. =( I configure my EP to do SSO with my R3, but I noticed that it is a totally separated thing.

Somebody could help telling me the general steps needed to achieve this ? I'm searching in help.sap.com but with no success.. =(

Thaaaanks in advance for your help!, best regards 😉

Diego

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • author's profile photo
    Former Member
    Posted on Dec 17, 2004 at 09:17 PM

    Hi Diego

    There is tons of information on this.

    Check this post

    problem-accessing-r3-with-sso-ticket-from-the-ep60

    and also links in this post.

    For Web dynpro app to R/3 these simple points should help

    -> Go to your Security provider service in VA , select the authentication template ticket and provide options for CreateTicketLoginModule with the one given in this document

    http://help.sap.com/saphelp_nw04/helpdata/en/cb/ac3d41a5a9ef23e10000000a155106/content.htm

    ->Go to your key storage service in VA and export out the certificate and import this into R/3

    ->Go to your Content administration for Web Dynpro and switch the security settings in your JCO destinations to use 'useSSO' instead of userid and password , this applies only for the destination that fetches application data. The meta data destination can be configured to use userid and password.

    Thats about it.

    Regards

    Pran

    P.S is this '=(' the mexican hat

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Pran,

      I realized that my EP instance has problems issuing the cookie (ticket). If i test another ep instances all of them issue the cookie without problem, except this one.

      I'm just ending a new EP installation (dev), I'll test the cookies and after that I'll configure SSO.

      I'll let you know the results.. and again, Thanks a lot for your help and time.

      Regards,

      Diego