Skip to Content
author's profile photo Former Member
Former Member

problem after deployment

Hello

I have a portal application with 2 iViews on EP6 SP6.

The first is a navigation, dependent on the link

user clicks in this iView, data is shown in the second iView.

Parameters a provided from the first to the second iView

by HttpSession object.

I have created a page and put the 2 iViews on it.

I am logged into Portal and see those iViews.

Now I make a change to the application and deploy it

from the Studio. After that I do a reload on the page

and get an error in the second portlet.

Without changing any code I log off the Portal, log in again, refresh both iViews and then the application

runs without error.

Can somone explain this? Have I to do a setting for (maybe?)

caching or something like that?

Or may there be an error in the second iView?

2nd problem: without any deployment in the meantime

I log in the Portal and navigate to the page with the 2 iViews. If I click on a link in the navigation iView

(which does a refresh by a javascript submit), I am

navigated in the Portal to a different page, in this case to

Java Develpoment \ Tools, which is the leftmost

page in my portal. Any idea on this?

thanks a lot

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 17, 2004 at 12:40 PM

    To your second problem the solution is to set the iView property "Isolation Method" to "URL". I´m affried I don't know the reason for this bug, but hope you can use the solution.

    Best regards

    Ole

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Dear Hans,

      yes it should do and brings You a little bit further to a "SessionManager".

      This is necessary for EP development because of HTTPSessionTimouts, ComponentSessionTimeout and so on and so on....

      Greetings

      Walter

  • author's profile photo Former Member
    Former Member
    Posted on Dec 17, 2004 at 01:37 PM

    Hello,

    I think the reason is, that the deployment destroys the Session. If this happen You receive a NullPointerException.

    You should check this with the debugger, System.outs....

    It this is the case You have to programm a view lines for Session handling and managing...

    Try it

    Walter

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.